Bug 893080 - Fontmatrix creates a deprecated $HOME/.fonts.conf file
Summary: Fontmatrix creates a deprecated $HOME/.fonts.conf file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fontmatrix
Version: 18
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-08 14:32 UTC by Göran Uddeborg
Modified: 2013-02-10 04:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-10 04:30:09 UTC


Attachments (Terms of Use)
move the .fonts.conf file location (3.62 KB, patch)
2013-01-09 04:05 UTC, Parag Nemade
no flags Details | Diff

Description Göran Uddeborg 2013-01-08 14:32:17 UTC
Description of problem:
According to the Fedora 18 release notes, $HOME/.fonts.conf is deprecated in favor of $HOME/.config/fontconfig/fonts.conf.  But fontmatrix still creates $HOME/.fonts.conf whenever it runs.

Version-Release number of selected component (if applicable):
fontmatrix-0.9.99-7.r1218.fc18.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. rm -r ~/.fonts.conf ~/.Fontmatrix
2. fntmatrix
  
Actual results:
A file ~/.fonts.conf is created.

Expected results:
~/.config/fontconfig/fonts.conf should probably be created instead.

Additional info:
One could argue this is an upstreams thing.  But since the upstreams project seems a bit hard to find, cf. bug 819159, I guess it has to be handled with a little patch instead.

Comment 1 Göran Uddeborg 2013-01-08 18:47:19 UTC
Since Paul Flo Williams pointed out in bug 819159 that fontmatrix lives in github these days, I've created an upstreams issue too.  Github does not seem to be listed among the possible "external trackers", but the URL to my report is 
https://github.com/fontmatrix/fontmatrix/issues/1

Comment 2 Parag Nemade 2013-01-09 04:03:47 UTC
I have added a pull request https://github.com/fontmatrix/fontmatrix/pull/2

Comment 3 Parag Nemade 2013-01-09 04:05:01 UTC
Created attachment 675235 [details]
move the .fonts.conf file location

Comment 4 Fedora Update System 2013-01-20 11:09:56 UTC
fontmatrix-0.9.99-8.r1218.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fontmatrix-0.9.99-8.r1218.fc18

Comment 5 Fedora Update System 2013-01-23 01:47:02 UTC
Package fontmatrix-0.9.99-8.r1218.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fontmatrix-0.9.99-8.r1218.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1251/fontmatrix-0.9.99-8.r1218.fc18
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-02-10 04:30:11 UTC
fontmatrix-0.9.99-8.r1218.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.