Bug 893097 - Adding host with already exist name results in exception in the engine
Adding host with already exist name results in exception in the engine
Status: CLOSED DUPLICATE of bug 893089
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Arik
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-08 10:17 EST by Arik
Modified: 2013-01-08 11:05 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 11:05:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arik 2013-01-08 10:17:12 EST
Description of problem:
Internal engine error when adding new host with already exist name

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. create host named "aa"
2. create another host named "aa"
3.
  
Actual results:
UI - dialog with "Error while executing action New Host: Internal Engine Error" is shown
backend - sql exception:
2013-01-08 17:09:09,040 ERROR [org.ovirt.engine.core.bll.AddVdsCommand] (http--0.0.0.0-8700-5) [6159c275] Command org.ovirt.engine.core.bll.AddVdsCommand throw exception: org.springframework.dao.DuplicateKeyException: CallableStatementCallback; SQL [{call insertvdsstatic(?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)}]; ERROR: duplicate key value violates unique constraint "vds_static_vds_name_unique"

Expected results:
no exception in the backend, better error in the UI

Additional info:
we found that in v3.0 we couldn't get into this scenario because the UI prevented the user from specifying an already exist name for new VM. the solution here should be in the backend also because of rest api.
Comment 1 Haim 2013-01-08 11:05:30 EST

*** This bug has been marked as a duplicate of bug 893089 ***

Note You need to log in before you can comment on or make changes to this bug.