Bug 893162 - /usr/bin/gnome-keyring-daemon coredumps at startup
Summary: /usr/bin/gnome-keyring-daemon coredumps at startup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-keyring
Version: 18
Hardware: ppc64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 894157
TreeView+ depends on / blocked
 
Reported: 2013-01-08 18:37 UTC by Karsten Hopp
Modified: 2015-03-03 23:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 894157 (view as bug list)
Environment:
Last Closed: 2013-01-20 15:43:19 UTC


Attachments (Terms of Use)
tarball of abrt files (1.35 MB, application/x-gzip)
2013-01-08 18:37 UTC, Karsten Hopp
no flags Details
Fix memrchr() call with negative string length (742 bytes, patch)
2013-01-10 20:19 UTC, Gustavo Luiz Duarte
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 691500 None None None Never

Description Karsten Hopp 2013-01-08 18:37:31 UTC
Created attachment 675001 [details]
tarball of abrt files

Description of problem:
/usr/bin/gnome-keyring-daemon coredumps at startup on PPC64, abrt files attached in a tarball

Version-Release number of selected component (if applicable):
gnome-keyring-3.6.2-2.fc18

Comment 1 Gustavo Luiz Duarte 2013-01-10 20:19:57 UTC
Created attachment 676525 [details]
Fix memrchr() call with negative string length

Please add the attached patch to the gnome-keyring package. This patch should fix this issue. It fixes an invalid call to memrchr() in libegg.

I could not reproduce this issue reliably as is, but Karsten pointed me to a variant of this bug that could be reproduced easily:
gnome-keyring import ~/.ssh/id_rsa

Although both gkr tool and gkr-daemon crash similarly, they have to be fixed in different places because they use different copies of the faulty libegg. While gkr-daemon uses its own copy of libegg linked statically, the gkr tool ends up using libegg through gcr, which also has libegg linked statically.
I will clone this bug and assign to gcr to get it fixed too.

Comment 2 Colin Walters 2013-01-10 22:10:28 UTC
Turned into "git format-patch" style against https://live.gnome.org/GnomeLove/SubmittingPatches and submitted upstream.  Should be reviewed by Stef.

Comment 3 Fedora Update System 2013-01-14 17:31:48 UTC
gcr-3.6.2-2.fc18,gnome-keyring-3.6.2-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gcr-3.6.2-2.fc18,gnome-keyring-3.6.2-3.fc18

Comment 4 Fedora Update System 2013-01-16 19:46:02 UTC
Package gcr-3.6.2-2.fc18, gnome-keyring-3.6.2-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gcr-3.6.2-2.fc18 gnome-keyring-3.6.2-3.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0884/gcr-3.6.2-2.fc18,gnome-keyring-3.6.2-3.fc18
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2013-02-01 16:33:34 UTC
gcr-3.6.2-2.fc18, gnome-keyring-3.6.2-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.