Bug 893302 - uhci_hcd Controller is using the wrong IRQ
uhci_hcd Controller is using the wrong IRQ
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
: 893305 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-08 23:42 EST by Suqin Huang
Modified: 2013-01-11 07:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 02:43:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2013-01-08 23:42:10 EST
Description of problem:
usb-tablet doesnt work when boot guest with -M q35

Version-Release number of selected component (if applicable):
qemu-kvm-1.3.0-3.el7.x86_64
seabios-1.7.2-0.2.gita810e4e7.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. cmd
/usr/libexec/qemu-kvm -nodefaults \
-device ich9-usb-uhci1,id=usb1,bus=pcie.0,addr=0x4 \
-drive file='/home/autotest-devel/client/tests/kvm/images/RHEL-Server-6.4-64-virtio.qcow2',if=none,id=drive-ide0-0-0,media=disk,cache=none,format=qcow2,aio=native \
-device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -device virtio-net-pci,netdev=idUMvixC,mac=9a:87:88:89:8a:8b,bus=pcie.0,addr=0x3,id='idMztaHV' -netdev tap,id=idUMvixC,vhost=on,script=/home/autotest-devel/client/virt/scripts/qemu-ifup-switch \
-m 2048 -smp 2,cores=1,threads=1,sockets=2 -cpu 'Opteron_G3' \
-device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 -vnc :0 -vga cirrus -rtc base=utc,clock=host,driftfix=slew  -boot order=cdn,once=c,menu=off   -no-kvm-pit-reinjection -enable-kvm -monitor stdio  \
-chardev socket,id=serial_id,path=/tmp/serial-shuang,server,nowait -device isa-serial,chardev=serial_id \
-M q35 
2.
3.
  
Actual results:
1). mouse doesn't work 
2). can be login via serial
3). network work well

Expected results:


Additional info:
1. guest dmesg

powernow-k8: Power state transitions not supported
powernow-k8: Power state transitions not supported
RPC: Registered named UNIX socket transport module.
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
mtrr: no MTRR for fc000000,100000 found
eth1: no IPv6 routers present
uhci_hcd 0000:00:04.0: Unlink after no-IRQ?  Controller is probably using the wrong IRQ.
fuse init (API version 7.13)
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts


2. host dmesg
[1373433.438479] kvm [24964]: vcpu0 unhandled rdmsr: 0xc001100d
[1373433.445994] kvm [24964]: vcpu0 unhandled rdmsr: 0xc0010112
[1373433.616372] kvm [24964]: vcpu0 unhandled rdmsr: 0xc0010001
[1373433.642474] kvm [24964]: vcpu1 unhandled rdmsr: 0xc001100d

3. host info:
kernel: 3.6.0-0.29.el7.x86_64
cpuinfo:
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs hw_pstate npt lbrv svm_lock

4. guest:
rhel6.4.64
Comment 2 Hai Huang 2013-01-09 15:28:18 EST
Please re-assign if this is a Q35 problem (i.e. not an uhci_hcb/usb issue).
Comment 3 Gerd Hoffmann 2013-01-10 01:33:01 EST
q35 in qemu 1.3 needs the dsdt passed in to work correctly:

"-acpitable file=/path/to/q35-acpi-dsdt.aml"

q35-acpi-dsdt.aml should come with seabios

Note that this is temporary, in qemu 1.4 it will not be needed any more (but wouldn't hurt either).
Comment 4 Suqin Huang 2013-01-11 00:19:19 EST
it works when adding -acpitable file=/path/to/q35-acpi-dsdt.aml
Comment 5 Gerd Hoffmann 2013-01-11 02:43:43 EST
Good, closing as upstream then as the upcoming qemu 1.4 should work fine.
Comment 6 Hai Huang 2013-01-11 07:18:56 EST
*** Bug 893305 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.