Bug 893335 - Guest network can't work after change mac address, when using vnic over macvtap
Guest network can't work after change mac address, when using vnic over macvtap
Status: CLOSED DUPLICATE of bug 848199
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Vlad Yasevich
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-09 01:53 EST by Qian Guo
Modified: 2014-02-19 12:01 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-19 12:01:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Qian Guo 2013-01-09 01:53:13 EST
Description of problem:
Boot a guest with vnic over macvtap, if change mac address inside guest, the guest's network could not work.

Version-Release number of selected component (if applicable):
qemu-kvm version:qemu-kvm-1.3.0-3.el7.x86_64
kernel verison:kernel-3.6.0-0.29.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.create a macvtap device, e.g.
# ip -d link show vepa1
11: vepa1@em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN mode DEFAULT qlen 500
    link/ether ce:b5:b9:3c:12:fd brd ff:ff:ff:ff:ff:ff
    macvtap  mode vepa 
2.boot a guest with a vnic over macvtap, and need assign the mac address of macvtap to this vnic.

3.inside guest, change the mac address of corresponding nic.
  
Actual results:
After change mac address, the guest lost network connection, this network could not work anymore.

Expected results:
After change mac address, network of the guest works well, or forbid change mac address when using macvtap.

Additional info:

When boot a guest w/ vnic over macvtap, mac address of the nic inside guest must be the same as the one of macvtap. So if change mac address inside guest, the guest's network could not work, but guest could not detect whether the nic is over macvtap. 

So if we really could not do mac_change over macvtap, we should document this to forbid users do this.
Comment 2 Amos Kong 2013-11-03 22:23:42 EST
If you also change the macaddr of host macvtap device to the new address, guest network will work.

The problem in this bug is that we don't sync the change to the host device.

We already have an QMP event to notify the management about the mac changing in guest, but the libvirt hasn't support to update the host device when it receives the event.

libvirt bug: https://bugzilla.redhat.com/show_bug.cgi?id=848199

So this bug's duplicated with bz 848199.
Comment 3 Vlad Yasevich 2014-02-19 12:01:41 EST
As comment 2 says, this BZ will be resolved once the functionality in BZ 848199 is made available.  Besides that, there is nothing more specific to do for this bug.  Closing as duplicate.

*** This bug has been marked as a duplicate of bug 848199 ***

Note You need to log in before you can comment on or make changes to this bug.