This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 893361 - [rhevm-backend] - Error for Windows guests which report unbounded value as interface name
[rhevm-backend] - Error for Windows guests which report unbounded value as in...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
high Severity high
: ---
: 3.2.0
Assigned To: Moti Asayag
Martin Pavlik
network
: Regression
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2013-01-09 03:18 EST by David Botzer
Modified: 2016-02-10 14:50 EST (History)
11 users (show)

See Also:
Fixed In Version: SF4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Windows Guest Error (118.88 KB, application/x-gzip)
2013-01-09 03:18 EST, David Botzer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10814 None None None Never

  None (edit)
Description David Botzer 2013-01-09 03:18:56 EST
Created attachment 675301 [details]
Windows Guest Error

Description of problem:
Error for Windows guests which report unbounded value as
interface name
netIfaces = [{'name': 'Red Hat VirtIO Ethernet Adapter - Packet
Scheduler Miniport', 'inet6': [], 'inet': ['10.16.34.154'], 'hw':
'00-1a-4a-23-61-69'}] 

Version-Release number of selected component (if applicable):
3.2/sf3

How reproducible:
always

Steps to Reproduce:
1.install 3.2 sf3, and add VMs - Windows & RHEL
2.examine the engine log for errors
  
Actual results:
Gives exception in log:
PSQLException: ERROR: value too long for type character varying(50)

Expected results:
should have this error

Additional info:
Caused by: org.postgresql.util.PSQLException: ERROR: value too long for type character varying(50)
  Where: SQL statement "INSERT INTO vm_guest_agent_interfaces(vm_id, interface_name, mac_address, ipv4_addresses, ipv6_addresses) VALUES( $1 ,  $2 ,  $3 ,  $4 ,  $5 )"
PL/pgSQL function "insertvmguestagentinterface" line 2 at SQL statement
        at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2062)
        at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1795)
        at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:257)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:479)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:367)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:360)
        at org.jboss.jca.adapters.jdbc.CachedPreparedStatement.execute(CachedPreparedStatement.java:297)
        at org.jboss.jca.adapters.jdbc.WrappedPreparedStatement.execute(WrappedPreparedStatement.java:404)
        at org.springframework.jdbc.core.JdbcTemplate$6.doInCallableStatement(JdbcTemplate.java:1066) [spring-jdbc-3.1.1.RELEASE.jar:3.1.1.RELEASE]
        at org.springframework.jdbc.core.JdbcTemplate$6.doInCallableStatement(JdbcTemplate.java:1) [spring-jdbc-3.1.1.RELEASE.jar:3.1.1.RELEASE]
        at org.springframework.jdbc.core.JdbcTemplate.execute(JdbcTemplate.java:1014) [spring-jdbc-3.1.1.RELEASE.jar:3.1.1.RELEASE]
        ... 22 more
Comment 1 David Botzer 2013-01-09 07:07:03 EST
Eli Mesika says:
Then column type in DB should be changed to text ...
Comment 3 David Botzer 2013-01-10 01:21:09 EST
Regression
Comment 6 David Botzer 2013-01-10 03:17:02 EST
Moti,
U know better than me, if u say netIfaces is 3.2 feature, than its not regression,
Thanks,
Comment 8 Mike Kolesnik 2013-01-10 10:45:07 EST
(In reply to comment #1)
> Eli Mesika says:
> Then column type in DB should be changed to text ...

I disagree that this is the best solution, we need to decide what's the maximal interface name that will be supported and if it's bigger truncate.
I don't think a NIC's name can be 2GB in size so no need to have it at that
Comment 9 Simon Grinberg 2013-01-17 06:53:07 EST
(In reply to comment #8)
> (In reply to comment #1)
> > Eli Mesika says:
> > Then column type in DB should be changed to text ...
> 
> I disagree that this is the best solution, we need to decide what's the
> maximal interface name that will be supported and if it's bigger truncate.
> I don't think a NIC's name can be 2GB in size so no need to have it at that

Is there a limit in Windows for that? Id so then please use max(windows,linux) as the upper bound.
Comment 10 Martin Pavlik 2013-01-28 09:34:51 EST
works in SF4
Comment 11 Itamar Heim 2013-06-11 05:29:15 EDT
3.2 has been released
Comment 12 Itamar Heim 2013-06-11 05:32:02 EDT
3.2 has been released
Comment 13 Itamar Heim 2013-06-11 05:47:51 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.