This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 89343 - PCMCIA startup script broken when used with a stock kernel (not OEM)
PCMCIA startup script broken when used with a stock kernel (not OEM)
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
http://members.cox.net/larona/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-22 14:12 EDT by Curtis Wood
Modified: 2015-01-04 17:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-26 23:31:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Curtis Wood 2003-04-22 14:12:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
On the Toshiba laptops, you need the ACPI patch from sourceforge to get things
running smoothely - this isn't the problem, it arises when you run this new
kernel. The PCMCIA startup scripts (/etc/init.d/pcmcia start) trys to "modprobe
yenta_socket.o" instead of "modprobe yenta_socket" - the is a result of seeing
if there is a directory "/lib/modules/`uname -r`/pcmcia" which there is; BUT if
you disable that section of code (line #102-the web page describes how), the
startup script works just fine and the PCMCIA starts working the way it is
suppose to. Simply what is happening is that modprobe cant find the module name
"yenta_socket.o" - i could be wrong (you guys are the gurus) but I thought that
insmod is used for loading the actual object files (inwhich it looks like it is
trying for some reason), and modprobe is for loading the module names
(crossreferenced to the object files). NOTE: The use of yenta_socket here is
just an example, since it is what is used on the Toshiba laptops...

Version-Release number of selected component (if applicable):
kernel-pcmcia-cs-3.1.31.-13

How reproducible:
Always

Steps to Reproduce:
1.Compile 2.4.19 - with PCMCIA compiled as a module
2.Install normally
3.reboot
    

Actual Results:  PCMCIA will not beep or anything...
Further investigation from the command line, with /etc/ini.t/pcmcia restart
results in "such-n-such module not found: such-n-such.o" simply put it is
probing for a module named as the object file, instead of the just the name...

Expected Results:  probing for module names and not the object file.

Additional info:

see description above... I dont know if you guys will interested in this or not,
but it is required to get the toshiba laptops working (atleast the 5205), but
also the main reason I doing this is that it look sto me like it is a bug in the
code, simply because if you disable that section  the rest of it works just fine...

Note You need to log in before you can comment on or make changes to this bug.