Bug 8935 - root can't login on console
root can't login on console
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: passwd (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-27 23:50 EST by Carl Eaton
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 18:55:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Eaton 2000-01-27 23:50:02 EST
If the owner in the passwd file = 0 then console will act
like a telnet-in and not allow root to login. Can login as
generic user with anything else than 0 for owner in passwd
file and then do a "su root" OK.

I do not have /etc/shadow and /etc/nologin files and the
/etc/securetty is correct (tty1 - tty8 only).

ADDITIONAL:
I was messing with setterm colors (with usual failure)
just prior to noticing this new occurance AND my system
was installed about a week ago.

Prior to setterm commands:  Loaded wu-ftp and
MD5 packages (only for/as a stated wu-ftp dependency?)
the day before.  MD5 came from from 6.1 CD's and
wu-ftp from 5.0 CD's since wu-ftp not found in 6.1.
Comment 1 Cristian Gafton 2000-05-22 11:36:59 EDT
assigned to nalin
Comment 2 Stephen John Smoogen 2003-01-24 18:55:24 EST
Bug 8935 was fixed between 6.1 and 7.3.

Note You need to log in before you can comment on or make changes to this bug.