This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 893562 - [engine-setup] Fails to setup ports when SElinux is disabled.
[engine-setup] Fails to setup ports when SElinux is disabled.
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
3.2
x86_64 Linux
urgent Severity medium
: ---
: 3.3
Assigned To: Alex Lourie
integration
: Regression
Depends On:
Blocks: 905443 953347
  Show dependency treegraph
 
Reported: 2013-01-09 08:09 EST by Kiril Nesenko
Modified: 2014-07-10 20:09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 905443 (view as bug list)
Environment:
Last Closed: 2013-09-23 03:35:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
logs (14.32 KB, text/x-log)
2013-01-09 08:09 EST, Kiril Nesenko
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11345 None None None Never

  None (edit)
Description Kiril Nesenko 2013-01-09 08:09:01 EST
Created attachment 675538 [details]
logs

Description of problem:
engine-setup fails to setup http port when selinux is disabled.

[root@vm-17-135 yum.repos.d]# engine-setup 
Welcome to oVirt Engine setup utility

In order to proceed the installer must stop the ovirt-engine service
Would you like to stop the ovirt-engine service? (yes|no): yes
 oVirt Engine uses httpd to proxy requests to the application server.
It looks like the httpd installed locally is being actively used.
The installer can override current configuration .
Alternatively you can use JBoss directly (on ports higher than 1024)
Do you wish to override current httpd configuration and restart the service? ['yes'| 'no']  [yes] : 
HTTP Port  [80] : 
Error: failed adding port 80 to http_port_t because it is already preallocated in selinux.
Please choose a different port.
HTTP Port  [80] : 8080
Error: failed adding port 8080 to http_port_t because it is already preallocated in selinux.
Please choose a different port.
HTTP Port  [80] : 9999
Error: failed adding port 9999 to http_port_t because it is already preallocated in selinux.
Please choose a different port.
HTTP Port  [80] : 5678
Error: failed adding port 5678 to http_port_t because it is already preallocated in selinux.
Please choose a different port.


Version-Release number of selected component (if applicable):
ovirt-engine-3.2.0-1.20130109.gitd1d2442.fc18.noarch

How reproducible:
Always

Steps to Reproduce:
1. Disable selinux and run setup.
2.
3.
  
Actual results:
Fails to setup ports

Expected results:
Need to print nice error message to a user - that selinux is disabled.

Additional info:
Comment 3 Sander Salazar 2013-01-17 19:50:10 EST
I'd like to confirm that as today,with a clean install and the system fully updated, the problem remains.
Comment 4 Charles Lacroix 2013-01-22 00:23:17 EST
I also get the same issue with ovirt 3.1 and selinux disabled.
Comment 5 Alex Lourie 2013-01-23 15:48:36 EST
patch uploaded for review: http://gerrit.ovirt.org/#/c/11345/
Comment 11 Dennis Böck 2013-02-21 04:11:26 EST
Today I was able to reproduce the (I thought patched) bug with the most current software of Fedora 18 and Ovirt 3.2.
Is there any other solution (workaround)?
Comment 12 Itamar Heim 2013-02-27 16:26:15 EST
(In reply to comment #11)
> Today I was able to reproduce the (I thought patched) bug with the most
> current software of Fedora 18 and Ovirt 3.2.
> Is there any other solution (workaround)?

Dennis - most recent as 'nightly', or 3.2 GA?
Comment 13 Dennis Böck 2013-03-04 03:52:46 EST
Sorry, I used 3.2 GA. I thought the patch is included, since it was finished before the 3.2 release.
Comment 14 Itamar Heim 2013-08-21 12:42:44 EDT
as RC is built, moving to ON_QA (hopefully did not catch incorrect bugs when doing this)
Comment 15 Itamar Heim 2013-09-23 03:35:38 EDT
closing as this should be in 3.3 (doing so in bulk, so may be incorrect)

Note You need to log in before you can comment on or make changes to this bug.