Bug 893763 - Java Service Wrapper failed to restart Windows servers with abnormal exit codes
Java Service Wrapper failed to restart Windows servers with abnormal exit codes
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Documentation (Show other bugs)
JON 3.1.0
All Windows
high Severity high
: ---
: ---
Assigned To: Deon Ballard
Mike Foley
:
Depends On: 893743
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-09 16:15 EST by Deon Ballard
Modified: 2013-11-22 18:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 893743
Environment:
Last Closed: 2013-11-22 18:46:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deon Ballard 2013-01-09 16:15:10 EST
+++ This bug was initially created as a clone of Bug #893743 +++

By design the Tanuki Java Service Wrapper wraps Windows server process and is supposed to restart the server on non-success exit codes.

In testing the latest AS7 based installer and server .bat scripts, and running RHQ as a Windows service, it seems that a restart is not happening even when we request an exit_code of 10 from AS7 (as part of the installer's current --reconfig processing)

This has likely been an issue for some time even though it has not to my knowledge been reported.  The fix may change (errant) behavior that some people may actually expect.

--- Additional comment from Jay Shaughnessy on 2013-01-09 15:33:20 EST ---

This turned out to actually be a bug in the wrapper itself.

master commit d471deebf1a579abe19f9a8755918e3344586cda
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Wed Jan 9 13:30:19 2013 -0500

    Update version of windows java wrapper from 3.2.0 to 3.3.1 to solve issues
    with exit code handling, which prevented proper restart of the rhq server
    after an rhq-installer --reconfig command, or any other non-success exit
    code situation.

master commit 66bcefdcb00beebab2fe2df8a13ba222e8a31a6a
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Wed Jan 9 14:34:26 2013 -0500

    Upping the JSW version for the agent to 3.3.1 to be the same as the
    recently updated server.



Test Notes
----------
An rhq-server.properties change (like smtp host) and then execution of the rhq-installer.bat --reconfig command should perform the config update and successfully restart the RHQ server on windows.
Comment 1 Deon Ballard 2013-01-15 15:04:09 EST
Targeting for JON 3.2, since this relates to the new AS7 server and installer.
Comment 2 Deon Ballard 2013-11-22 18:46:11 EST
With the rhqctl script, this (old) bug is not an issue.

Note You need to log in before you can comment on or make changes to this bug.