This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 893779 - Gluster 3.3.1 NFS service died after
Gluster 3.3.1 NFS service died after
Status: CLOSED DUPLICATE of bug 893778
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.3.0
x86_64 Linux
medium Severity unspecified
: ---
: ---
Assigned To: Rajesh
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-09 16:51 EST by Rob
Modified: 2013-07-04 18:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-28 02:04:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rob 2013-01-09 16:51:23 EST
Description of problem:
Gluster NFS service died.

Version-Release number of selected component (if applicable):
3.3.1

How reproducible:
Unsure. 

Steps to Reproduce:
1. Mount the NFS storage
2. Write a bunch of data
3. Gluster NFS service died
  
Actual results:

Gluster NFS service died.

Expected results:

Gluster NFS service stays up.

Additional info:

Relevant logs are below:

[2013-01-09 14:46:37.198861] W [quota.c:2177:quota_fstat_cbk] 0-RedhawkShared-quota: quota context not set in inode (gfid:1d16621a-b000-401b-b51e-f554f201705a)

pending frames:

patchset: git://git.gluster.com/glusterfs.git
signal received: 6
time of crash: 2013-01-09 16:33:06
configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.3.1
/lib64/libc.so.6[0x381c832920]
/lib64/libc.so.6(gsignal+0x35)[0x381c8328a5]
/lib64/libc.so.6(abort+0x175)[0x381c834085]
/lib64/libc.so.6[0x381c86fa37]
/lib64/libc.so.6(__fortify_fail+0x37)[0x381c9012a7]
/lib64/libc.so.6(__fortify_fail+0x0)[0x381c901270]
/usr/lib64/glusterfs/3.3.1/xlator/nfs/server.so(+0x30f47)[0x7f597f9a9f47]
/usr/lib64/libgfrpc.so.0(rpcsvc_handle_rpc_call+0x293)[0x3c9e40a443]
/usr/lib64/libgfrpc.so.0(rpcsvc_notify+0x93)[0x3c9e40a5b3]
/usr/lib64/libgfrpc.so.0(rpc_transport_notify+0x28)[0x3c9e40b018]
/usr/lib64/glusterfs/3.3.1/rpc-transport/socket.so(socket_event_poll_in+0x34)[0x7f5985236924]
/usr/lib64/glusterfs/3.3.1/rpc-transport/socket.so(socket_event_handler+0xc7)[0x7f5985236a07]
/usr/lib64/libglusterfs.so.0[0x3c9e03ed14]
/usr/sbin/glusterfs(main+0x58a)[0x40741a]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x381c81ecdd]
/usr/sbin/glusterfs[0x4043c9]
---------
Comment 2 Amar Tumballi 2013-01-10 01:54:34 EST
please share 'gluster volume info' to help us understand what were the exact options set on the volume.
Comment 3 Rob 2013-01-10 15:05:22 EST
# gluster volume info RedhawkShared
 
Volume Name: RedhawkShared
Type: Replicate
Volume ID: f9b943f8-dcb9-448f-a8b2-795d3c19ef3d
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: mualglup01:/mnt/gluster/RedhawkShared
Brick2: mualglup02:/mnt/gluster/RedhawkShared
Options Reconfigured:
features.limit-usage: /robinr:1GB
features.quota: on
auth.allow: 10.0.72.135,10.0.93.*,192.168.251.*
nfs.disable: off
nfs.register-with-portmap: 1

### I have the core dump if you wish it to be uploaded.
### Platform Redhat 6.2.
Comment 4 Rob 2013-01-10 15:07:08 EST
The problem was observed in gluster-3.3.1-1 RPM. 
Once reverted to gluster-3.3.0-1, the problem went away.

I could not reproduce it successfully in my test machines.
Comment 5 Rajesh 2013-01-28 01:21:58 EST
Please upload the core dump if you still have it. Is it not reproducible with 3.3.1-1 rpms too?
Comment 6 Rob 2013-01-28 01:44:37 EST
It seems that I may have accidentally filed the same bug report.

Please refer to:
https://bugzilla.redhat.com/show_bug.cgi?id=893778

I've uploaded the core dumps there.

The bug id 893778 also has another user having the same backtrace and exhibit the same issues with NFS on the same verison.
Comment 7 Rajesh 2013-01-28 02:04:29 EST

*** This bug has been marked as a duplicate of bug 893778 ***

Note You need to log in before you can comment on or make changes to this bug.