Bug 893920 - [RHEVM] RHEVH-Configure Local Storage: Error while executing action New Local Storage Domain: Remote path is illegal
[RHEVM] RHEVH-Configure Local Storage: Error while executing action New Local...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
x86_64 Linux
urgent Severity urgent
: ---
: 3.2.0
Assigned To: Alon Bar-Lev
Leonid Natapov
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-10 04:07 EST by Lijun Li
Modified: 2016-02-10 13:32 EST (History)
14 users (show)

See Also:
Fixed In Version: SF4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Set the path to your local storage (131.61 KB, image/png)
2013-01-10 04:13 EST, Lijun Li
no flags Details
Error while executing action New Local Storage Domain: Remote path is illegal (93.73 KB, image/png)
2013-01-10 04:15 EST, Lijun Li
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10965 None None None Never

  None (edit)
Description Lijun Li 2013-01-10 04:07:20 EST
Description of problem:
Error while executing action New Local Storage Domain: Remote path is illegal

When use the 'Configure Local Storage' to configure the rhev-h host in rhevm, got the above error.

Version-Release number of selected component (if applicable):

rhevm sf3 build:
[root@rhevm32 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.4 Beta (Santiago)
[root@rhevm32 ~]# rpm -q rhevm rhevm-webadmin-portal
rhevm-3.2.0-4.el6ev.noarch
rhevm-webadmin-portal-3.2.0-4.el6ev.noarch

rhev-h:
[root@rhevh64 ~]# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 6.4 (20121212.1)
[root@rhevh64 ~]# rpm -q vdsm
vdsm-4.10.2-1.0.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install the latest rhevm3.2 sf3 build.
2. Login Web Admin Portal and add the Hypervisor host to the rhevm.
3. Use the Hosts resource tab, tree mode, click Maintenance to place the rhevh host into maintenance mode.
4. Click 'Configure Local Storage' to open the Configure Local Storage window. 
5. Keep the default rhevh  local storage path '/data/images/'. 
6. Click OK.

  
Actual results:
Error while executing action New Local Storage Domain: Remote path is illegal

Expected results:
1. the rhevh local storage path should be '/data/images' but no '/data/images/'.
2. Complete 'Configure Local Storage' task.

Additional info:
Also please see the attached screen-shot and engine.log.
Comment 1 Lijun Li 2013-01-10 04:13:58 EST
Created attachment 676181 [details]
Set the path to your local storage
Comment 2 Lijun Li 2013-01-10 04:15:33 EST
Created attachment 676182 [details]
Error while executing action New Local Storage Domain: Remote path is illegal
Comment 3 Lijun Li 2013-01-10 04:18:57 EST
======engine.log=============
2013-01-10 01:59:23,286 INFO  [org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand] (ajp-/127.0.0.1:8702-13) [_WEBADMIN_16940142_Configure_Local_Storage] Running command: AddLocalStorageDomainCommand internal: false. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: System
2013-01-10 01:59:23,301 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateStorageDomainVDSCommand] (ajp-/127.0.0.1:8702-13) [_WEBADMIN_16940142_Configure_Local_Storage] START, CreateStorageDomainVDSCommand(HostName = rhevh64.redhat.com, HostId = 8272683e-210d-4e08-b2cc-18fbb29cd04e, storageDomain=org.ovirt.engine.core.common.businessentities.StorageDomainStatic@beab2cc2, args=/data/images/), log id: 440174e1
2013-01-10 01:59:27,926 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp-/127.0.0.1:8702-13) [_WEBADMIN_16940142_Configure_Local_Storage] Failed in CreateStorageDomainVDS method
2013-01-10 01:59:27,927 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp-/127.0.0.1:8702-13) [_WEBADMIN_16940142_Configure_Local_Storage] Error code StorageDomainIllegalRemotePath and error message VDSGenericException: VDSErrorException: Failed to CreateStorageDomainVDS, error = Remote path is illegal: ('/data/images/',)
2013-01-10 01:59:27,927 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp-/127.0.0.1:8702-13) [_WEBADMIN_16940142_Configure_Local_Storage] Command org.ovirt.engine.core.vdsbroker.vdsbroker.CreateStorageDomainVDSCommand return value 
 Class Name: org.ovirt.engine.core.vdsbroker.vdsbroker.StatusOnlyReturnForXmlRpc
mStatus                       Class Name: org.ovirt.engine.core.vdsbroker.vdsbroker.StatusForXmlRpc
mCode                         390
mMessage                      Remote path is illegal: ('/data/images/',)


2013-01-10 01:59:27,928 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp-/127.0.0.1:8702-13) [_WEBADMIN_16940142_Configure_Local_Storage] HostName = rhevh64.redhat.com
2013-01-10 01:59:27,928 ERROR [org.ovirt.engine.core.vdsbroker.VDSCommandBase] (ajp-/127.0.0.1:8702-13) [_WEBADMIN_16940142_Configure_Local_Storage] Command CreateStorageDomainVDS execution failed. Exception: VDSErrorException: VDSGenericException: VDSErrorException: Failed to CreateStorageDomainVDS, error = Remote path is illegal: ('/data/images/',)
2013-01-10 01:59:27,928 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateStorageDomainVDSCommand] (ajp-/127.0.0.1:8702-13) [_WEBADMIN_16940142_Configure_Local_Storage] FINISH, CreateStorageDomainVDSCommand, log id: 440174e1
2013-01-10 01:59:27,928 ERROR [org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand] (ajp-/127.0.0.1:8702-13) [_WEBADMIN_16940142_Configure_Local_Storage] Command org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand throw Vdc Bll exception. With error message VdcBLLException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to CreateStorageDomainVDS, error = Remote path is illegal: ('/data/images/',)
2013-01-10 01:59:27,933 INFO  [org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand] (ajp-/127.0.0.1:8702-13) [_WEBADMIN_16940142_Configure_Local_Storage] Command [id=e07f8daf-c130-400d-9198-7bc18ebb8841]: Compensating NEW_ENTITY_ID of org.ovirt.engine.core.common.businessentities.StorageDomainDynamic; snapshot: 712ba8e0-953c-4b14-baf4-f9b4ff60e1ee.
2013-01-10 01:59:27,935 INFO  [org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand] (ajp-/127.0.0.1:8702-13) [_WEBADMIN_16940142_Configure_Local_Storage] Command [id=e07f8daf-c130-400d-9198-7bc18ebb8841]: Compensating NEW_ENTITY_ID of org.ovirt.engine.core.common.businessentities.StorageDomainStatic; snapshot: 712ba8e0-953c-4b14-baf4-f9b4ff60e1ee.
2013-01-10 01:59:27,946 ERROR [org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand] (ajp-/127.0.0.1:8702-13) [_WEBADMIN_16940142_Configure_Local_Storage] Transaction rolled-back for command: org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand.
2013-01-10 01:59:28,577 INFO  [org.ovirt.engine.core.bll.storage.RemoveStorageServerConnectionCommand] (ajp-/127.0.0.1:8702-5) [_WEBADMIN_16940142_Configure_Local_Storage] Running command: RemoveStorageServerConnectionCommand internal: false. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: System
2013-01-10 01:59:28,580 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStorageServerVDSCommand] (ajp-/127.0.0.1:8702-5) [_WEBADMIN_16940142_Configure_Local_Storage] START, DisconnectStorageServerVDSCommand(HostName = rhevh64.redhat.com, HostId = 8272683e-210d-4e08-b2cc-18fbb29cd04e, storagePoolId = 00000000-0000-0000-0000-000000000000, storageType = LOCALFS, connectionList = [{ id: null, connection: /data/images/, iqn: null, vfsType: null, mountOptions: null, nfsVersion: null, nfsRetrans: null, nfsTimeo: null };]), log id: 45086c27
2013-01-10 01:59:32,739 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStorageServerVDSCommand] (ajp-/127.0.0.1:8702-5) [_WEBADMIN_16940142_Configure_Local_Storage] FINISH, DisconnectStorageServerVDSCommand, return: {00000000-0000-0000-0000-000000000000=0}, log id: 45086c27
2013-01-10 01:59:34,345 INFO  [org.ovirt.engine.core.bll.LoginUserCommand] (ajp-/127.0.0.1:8702-10) Checking if user admin@internal is an admin, result true
2013-01-10 01:59:34,345 INFO  [org.ovirt.engine.core.bll.LoginUserCommand] (ajp-/127.0.0.1:8702-10) Running command: LoginUserCommand internal: false.
2013-01-10 01:59:34,370 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (ajp-/127.0.0.1:8702-10) calling GetConfigurationValueQuery (ApplicationMode) with null version, using default general for version
2013-01-10 01:59:34,371 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (ajp-/127.0.0.1:8702-10) calling GetConfigurationValueQuery (VdcVersion) with null version, using default general for version
2013-01-10 02:00:00,001 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-87) Checking autorecoverable hosts
2013-01-10 02:00:00,009 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-87) Autorecovering 0 hosts
2013-01-10 02:00:00,009 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-87) Checking autorecoverable hosts done
2013-01-10 02:00:00,009 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-87) Autorecovering storage domains is disabled, skipping
2013-01-10 02:00:34,337 INFO  [org.ovirt.engine.core.bll.LoginUserCommand] (ajp-/127.0.0.1:8702-2) Checking if user admin@internal is an admin, result true
2013-01-10 02:00:34,337 INFO  [org.ovirt.engine.core.bll.LoginUserCommand] (ajp-/127.0.0.1:8702-2) Running command: LoginUserCommand internal: false.
2013-01-10 02:00:34,364 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (ajp-/127.0.0.1:8702-2) calling GetConfigurationValueQuery (ApplicationMode) with null version, using default general for version
2013-01-10 02:00:34,364 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (ajp-/127.0.0.1:8702-2) calling GetConfigurationValueQuery (VdcVersion) with null version, using default general for version
Comment 4 Lijun Li 2013-01-11 03:11:19 EST
The path should be '/data/images/rhev'.
Comment 5 Alon Bar-Lev 2013-01-13 14:15:24 EST
Correct.

This was a bug introduced at[1], due to mixup with the two functions of /data.

[1] http://gerrit.ovirt.org/#/c/9156/3
Comment 6 Alon Bar-Lev 2013-01-13 14:25:11 EST
http://gerrit.ovirt.org/#/c/10965/
Comment 7 Alon Bar-Lev 2013-01-13 14:31:59 EST
As a work around you can change the configuration RhevhLocalFSPath to /data/images/rhev

# psql -d engine -U postgres -c "update vdc_options set option_value='/data/images/rhev' where option_name='RhevhLocalFSPath';"
Comment 12 Leonid Natapov 2013-03-04 09:45:26 EST
sf9. successfully created local storage on RHEVH node in /data/images.
Comment 13 Itamar Heim 2013-06-11 05:52:35 EDT
3.2 has been released
Comment 14 Itamar Heim 2013-06-11 05:52:46 EDT
3.2 has been released
Comment 15 Itamar Heim 2013-06-11 05:59:16 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.