Bug 893972 - the plplot-devel rpm is missing dependencies
the plplot-devel rpm is missing dependencies
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: plplot (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-10 07:18 EST by David Howells
Modified: 2013-08-01 13:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 13:55:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test script (3.18 KB, application/octet-stream)
2013-01-10 07:18 EST, David Howells
no flags Details
ephcom2 sources (165.84 KB, application/octet-stream)
2013-01-10 07:21 EST, David Howells
no flags Details
te_gen sources (100.28 KB, application/octet-stream)
2013-01-10 07:22 EST, David Howells
no flags Details

  None (edit)
Description David Howells 2013-01-10 07:18:15 EST
Created attachment 676277 [details]
Test script

Description of problem:

I'm trying to build te_gen from the time-ephemeris project with full testing enabled.  This includes running cmake in the te_gen directory and telling it where to find the cmake export files for plplot development as te_gen uses plplot as part of its testing.

This doesn't work, however, as the /usr/share/plplot5.9.9/examples/cmake/modules/export_plplot-noconfig.cmake file has a bunch of dependencies on plplot subpackages that the plplot-devel rpm doesn't know about.

Version-Release number of selected component (if applicable):

plplot-devel-5.9.9-7.svn12202.fc17.x86_64

How reproducible:

100%

Steps to Reproduce:

This is slightly complicated as ephcom2 has to be built first and data has to be supplied.  I will attach a pair of source tarballs and a script to download the data and do all the building.

1. Unpack the ephcom2 and te_gen tarballs.

2. Configure the script.  This means altering the paths at the top of it.  JPL_DATA_DIR needs to point to where the data should be downloaded.  INPOP_DATA_DIR can just point to /tmp - we don't need that data.  EPHCOM_DIR and TE_GEN_DIR need to point to the sources you unpacked in step 1.  INSTALL_DIR and INSTALL_BUILD_DIR are just a pair of scratch directories.  PLPLOT_MODULE_PATH should point to where the plplot cmake modules are installed.

3. Run the script.

Actual results:

cmake fails with things like this:

 CMake Error at /usr/share/plplot5.9.9/examples/cmake/modules/export_plplot-
 noconfig.cmake:359 (MESSAGE):
  The imported target "tclmatrixd" references the file
     "/usr/lib64/libtclmatrixd.so.9.2.0"

Indicating plplot-tk is not installed.

 CMake Error at /usr/share/plplot5.9.9/examples/cmake/modules/export_plplot-
 noconfig.cmake:359 (MESSAGE):
  The imported target "plplot_octave" references the file
     "/usr/lib64/octave/site/oct/x86_64-redhat-linux-gnu/plplot_octave.oct"

Indicating plplot-octave is not installed.

 CMake Error at /usr/share/plplot5.9.9/examples/cmake/modules/export_plplot-
 noconfig.cmake:359 (MESSAGE):
  The imported target "plplotwxwidgetsd" references the file
     "/usr/lib64/libplplotwxwidgetsd.so.0.0.0"

Indicating plplot-wxGTK is not installed.

 CMake Error at /usr/share/plplot5.9.9/examples/cmake/modules/export_plplot-
 noconfig.cmake:359 (MESSAGE):
  The imported target "plplotadad" references the file
     "/usr/lib64/libplplotadad.so.0.0.0"

Indicating plplot-ada is not installed.

 CMake Error at /usr/share/plplot5.9.9/examples/cmake/modules/export_plplot-
 noconfig.cmake:359 (MESSAGE):
  The imported target "plplotluac" references the file
     "/usr/lib64/lua/5.1/plplot/plplotluac.so"

Indicating plplot-lua is not installed.

Expected results:

cmake shouldn't show up such errors.

Additional info:
Comment 1 David Howells 2013-01-10 07:21:26 EST
Created attachment 676279 [details]
ephcom2 sources
Comment 2 David Howells 2013-01-10 07:22:11 EST
Created attachment 676280 [details]
te_gen sources
Comment 3 Orion Poplawski 2013-01-10 22:34:38 EST
Hmm.  I'm more tempted to change FATAL_ERROR to WARNING at line 359 of export_plplot-noconfig.cmake.  At least in the case of te_gen none of the other plplot packages are actually needed for building it.  And you *really* don't want to pull in *all* of the plplot sub-packages and their deps.

I'll try to chat with upstream and get their take on it as well.
Comment 4 Fedora End Of Life 2013-07-04 02:23:09 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2013-08-01 13:55:41 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.