Bug 893994 - detect severity conflicts in updateinfo.xml
Summary: detect severity conflicts in updateinfo.xml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum
Version: 6.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Valentina Mukhamedzhanova
QA Contact: Karel Srot
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-10 13:36 UTC by Karel Srot
Modified: 2015-07-22 07:20 UTC (History)
3 users (show)

Fixed In Version: yum-3.2.29-62.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 07:20:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1384 normal SHIPPED_LIVE yum bug fix and enhancement update 2015-07-20 18:07:41 UTC

Description Karel Srot 2013-01-10 13:36:51 UTC
Description of problem:

Bug 737173 - yum doesn't merge updateinfo from multiple repositories
implemeted merging updateinfo from multiple repos.

It also warns the user if there is a mismatch in various updateinfo data but doesn't warn the user in case there is a mismatch in severity.

Severity has been added to updateinfo in bug 624079

Version-Release number of selected component (if applicable):
yum-3.2.29-40.el6.noarch

How reproducible:
always

Steps to Reproduce:
for details see
https://bugzilla.redhat.com/show_bug.cgi?id=737173
especially #c18
  
Actual results:
no warning in case severity differs

Expected results:
warning

Comment 2 RHEL Product and Program Management 2013-10-14 00:05:59 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 3 Valentina Mukhamedzhanova 2014-12-16 13:46:25 UTC
Upstream patch can be applied cleanly - http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=b52cecf339bd1731bcbfcc3243ba4f39242bb854

Comment 7 errata-xmlrpc 2015-07-22 07:20:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1384.html


Note You need to log in before you can comment on or make changes to this bug.