Bug 894036 - Use sparse monitor config instead of continuous
Summary: Use sparse monitor config instead of continuous
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-vdagent
Version: 6.4
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Hans de Goede
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks: 921152
TreeView+ depends on / blocked
 
Reported: 2013-01-10 15:05 UTC by Tomas Jamrisko
Modified: 2013-11-21 06:24 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-11-21 06:24:11 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1560 normal SHIPPED_LIVE spice-vdagent bug fix and enhancement update 2013-11-20 21:40:19 UTC

Description Tomas Jamrisko 2013-01-10 15:05:14 UTC
Description of problem:
Currently used monitor-config message uses continuous range of monitors, which forces the user to use a continuous display configuration.

Copying from BZ#881072

...Reopening of closed display has been fixed, one different issue has surfaced:
  -- for some reason the client always tries to establish connection on first n available displays, where n is number of windows open. Which results in: 
     -- user being unable to open displays out of order (e.g. instead of having displays 1, 3 and 4; he gets 1, 2, 3)
        -- this might be considered as OK, but remote viewer actually states it's waiting for the selected display and ends up with the wrong one. 
        -- the bigger issue related to this behaviour is: 
           -- user has no control of which display actually gets closed, when he closes a window.
              -- when user closes a window, then after a short period of time, the configuration alters in this way: It closes the highest open display, and maintains the first n displays open. Example for a use case, where this is wrong: 
user opened displays 1, 2, 3. Works mostly on displays 1,3, decides to close 2. After a short timeout, display 3 gets closed, 2 reopened, and work from 3 gets rearranged between 1 and 2. The expected way is obviously keeping 1, 3 open, closing 2.
...

Version-Release number of selected component (if applicable):
spice-vdagent-0.12.0-4.el6
spice-gtk-0.14-7.el6

How reproducible:
Always 




Additional info:

Comment 3 Hans de Goede 2013-03-09 19:25:00 UTC
I'm doing a new build for 6.5: spice-vdagent-0.12.0-5.el6.

This new build brings in a whole set of interdependent patches from upstream to fix bug 881020, this includes the fix for this -> moving to MODIFIED.

Comment 7 errata-xmlrpc 2013-11-21 06:24:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1560.html


Note You need to log in before you can comment on or make changes to this bug.