Bug 894056 - The support of V3 certificates is not enabled on the server and is required for large content set subscription
The support of V3 certificates is not enabled on the server and is required f...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity high
: rc
: 1.3
Assigned To: Adam Price
Og Maciel
: Triaged
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-01-10 10:54 EST by Jakub Dorňák
Modified: 2013-10-01 06:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 06:55:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/rhsm/rhsm.log (28.32 KB, text/x-log)
2013-01-10 10:54 EST, Jakub Dorňák
no flags Details

  None (edit)
Description Jakub Dorňák 2013-01-10 10:54:12 EST
Created attachment 676399 [details]
/var/log/rhsm/rhsm.log

Description of problem:
Cannot subscribe system using SAM.

Version-Release number of selected component (if applicable):

subscription-manager-0.99.19-1.el6.x86_64.rpm
subscription-manager-1.0.24-1.el5.x86_64.rpm
subscription-manager-1.1.18-1.el6.x86_64.rpm

katello-certs-tools-1.2.1-1h.el6_3.noarch
katello-cli-1.2.1-11h.el6_3.noarch
katello-headpin-1.2.1-12h.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.2.1-11h.el6_3.noarch
katello-glue-candlepin-1.2.1-12h.el6_3.noarch
katello-selinux-1.2.1-2h.el6_3.noarch
katello-headpin-all-1.2.1-12h.el6_3.noarch
katello-common-1.2.1-12h.el6_3.noarch
katello-configure-1.2.3-1h.el6_3.noarch


Steps to Reproduce:
1. Install and deploy last nightly build of SAM
2. Upload manifest file containing Red Hat Employee Subscription
3. Try to register some system


Actual results:
[root@hp-dl385-01 ~]# subscription-manager register --autosubscribe
Username: root
Password: 
The system has been registered with id: 62cd42b3-4da9-44b2-9086-e40ad00d0834 
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Not Subscribed

[root@hp-dl385-01 ~]# subscription-manager list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name:    	Red Hat Employee Subscription
SKU:                  	SYS0395
Pool Id:              	8a90aa693c1f0986013c24f8fbc40ed2
Quantity:             	50
Service Level:        	None
Service Type:         	None
Multi-Entitlement:    	No
Ends:                 	26.09.2013
Machine Type:         	physical

[root@hp-dl385-01 ~]# subscription-manager subscribe --pool 8a90aa693c1f0986013c24f8fbc40ed2
The support of V3 certificates is not enabled on the server and is required for large content set subscription: Red Hat Employee Subscription
[root@hp-dl385-01 ~]# 


Expected results:
System should be subscribed after the first command.
Comment 1 gaoshang 2013-01-11 00:41:47 EST
We have opened a bug 890000[1] which I think have the same root cause with this bug. 
Michael added a method to enable V3 certificates.

[1]https://bugzilla.redhat.com/show_bug.cgi?id=890000
Comment 2 Bryan Kearney 2013-06-06 12:58:21 EDT
This should be in the current SAM build of 1.3
Comment 3 Og Maciel 2013-08-16 15:49:31 EDT
[root@ibm-x3550m3-07 ~]# subscription-manager register --autosubscribe
Username: $USER
Password:
The system has been registered with id: ee1dd3b6-2fcb-4969-9b43-633f4642667e
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed

[root@ibm-x3550m3-07 ~]# subscription-manager list --available
No available subscription pools to list
[root@ibm-x3550m3-07 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+

Subscription Name:    	Red Hat Employee Subscription
Provides:             	Red Hat Enterprise Linux Load Balancer (for RHEL Server)
                      	Red Hat Enterprise Linux Workstation
                      	Red Hat Enterprise Linux Server
                      	Red Hat Enterprise Linux High Availability (for RHEL Server)
                      	Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
SKU:                  	XXXXXXX
Contract:             	XXXXXXX
Account:              	XXXXXXX
Serial Number:        	XXXXXXXXXXXXXX
Active:               	True
Quantity Used:        	1
Service Level:        	None
Service Type:         	None
Starts:               	09/27/2012
Ends:                 	09/26/2013
Comment 4 Og Maciel 2013-08-16 15:50:38 EDT
Verified:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.20-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.20-1.el6sat.noarch
* signo-katello-0.0.20-1.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 6 errata-xmlrpc 2013-10-01 06:55:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.