This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 894181 - For an ADS user - when ADS is down no error message is shown in login screen
For an ADS user - when ADS is down no error message is shown in login screen
Status: CLOSED WONTFIX
Product: Subscription Asset Manager
Classification: Red Hat
Component: Signo (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Marek Hulan
Og Maciel
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-01-10 17:58 EST by sthirugn@redhat.com
Modified: 2013-07-23 15:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 15:52:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sthirugn@redhat.com 2013-01-10 17:58:03 EST
Description of problem:
When an ADS user tries to login SAM when the ADS server is actually down - the log in page just refreshes without any error message.

Version-Release number of selected component (if applicable):
* candlepin-0.7.23-1.el6_3.noarch
* candlepin-tomcat6-0.7.23-1.el6_3.noarch
* elasticsearch-0.19.9-5.el6_3.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.2.1-1h.el6_3.noarch
* katello-cli-1.2.1-11h.el6_3.noarch
* katello-cli-common-1.2.1-11h.el6_3.noarch
* katello-common-1.2.1-12h.el6_3.noarch
* katello-configure-1.2.3-1h.el6_3.noarch
* katello-glue-candlepin-1.2.1-12h.el6_3.noarch
* katello-headpin-1.2.1-12h.el6_3.noarch
* katello-headpin-all-1.2.1-12h.el6_3.noarch
* katello-selinux-1.2.1-2h.el6_3.noarch
* thumbslug-0.0.28-1.el6_3.noarch
* thumbslug-selinux-0.0.28-1.el6_3.noarch


How reproducible:
All Times

Steps to Reproduce:
1. yum install -y katello-headpin-all
2. katello-configure --deployment=sam [add options supporting AD configuration]
3. When ADS server is down, attempt to login to SAM UI using AD user credentials (Eg. Administrator/*****)
  
Actual results:
The log in page refreshes without any error message.

Expected results:
Error message saying ADS is not responding.

Additional info:
Comment 1 Tom McKay 2013-07-23 15:52:42 EDT
This BZ is obsolete due to introduction of "signo" signal sign on module replacement.

Please re-open against signo component if problems persist.

Note You need to log in before you can comment on or make changes to this bug.