Bug 894185 - Logwatch does not handle "improper command pipelining after (NOOP|RSET)"
Summary: Logwatch does not handle "improper command pipelining after (NOOP|RSET)"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: logwatch
Version: 6.3
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jan Synacek
QA Contact: Ondrej Hudlicky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-10 23:31 UTC by Robert Scheck
Modified: 2018-12-02 18:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-10 13:40:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
[Patch] handle "improper command pipelining" message correctly (1.42 KB, patch)
2013-01-14 14:18 UTC, Jan Synacek
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1247 0 normal SHIPPED_LIVE logwatch bug fix update 2013-09-10 17:38:05 UTC

Description Robert Scheck 2013-01-10 23:31:47 UTC
Description of problem:
Logwatch does not handle "improper command pipelining after (NOOP|RSET)" as
it is shipped right now with RHEL 6. Reproducing is easily possible, simply
add "reject_unauth_pipelining" to "smtpd_recipient_restrictions" in main.cf
and get a dumb spammer who didn't learn to behave according to SMTP RFCs.

Version-Release number of selected component (if applicable):
logwatch-7.3.6-49.el6.noarch

How reproducible:
Everytime, see above and below.
  
Actual results:
Logwatch does not handle "improper command pipelining after (NOOP|RSET)"

Expected results:
Logwatch should handle "improper command pipelining after (NOOP|RSET)"

Additional info:
According to logwatch upstream there seems to be a patch for this already:
http://sourceforge.net/mailarchive/forum.php?forum_name=logwatch-devel&max_rows=25&style=nested&viewmonth=201009

Comment 2 Robert Scheck 2013-01-11 00:00:46 UTC
Actually, we see NOOP/RSET/HELO in the wild currently, the patch covers them
all - which is likely the best.

Cross-filed case 00775789 in the Red Hat customer portal.

Comment 3 Jan Synacek 2013-01-14 14:18:01 UTC
Created attachment 678237 [details]
[Patch] handle "improper command pipelining" message correctly

Comment 4 Jan Synacek 2013-01-14 14:25:07 UTC
Testing package:

http://people.redhat.com/jsynacek/logwatch/logwatch-7.3.6-50.el6.noarch.rpm

Comment 5 Robert Scheck 2013-01-18 10:05:42 UTC
Applying this package removes the patch from bug #799987 - which unfortunately
still did not make it into any stable release yet.

Comment 6 Robert Scheck 2013-01-18 12:15:20 UTC
The testing RPM fixes the initially described issue for me, however comment #5
applies for that testing package.

Comment 13 errata-xmlrpc 2013-09-10 13:40:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1247.html


Note You need to log in before you can comment on or make changes to this bug.