This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 894191 - Logwatch doesn't proper ignore "password check failed for user"
Logwatch doesn't proper ignore "password check failed for user"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: logwatch (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jan Synacek
Ondrej Hudlicky
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-10 19:06 EST by Robert Scheck
Modified: 2014-01-30 04:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 894272 (view as bug list)
Environment:
Last Closed: 2013-09-10 09:40:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
[Patch] handle usernames correctly (1.04 KB, patch)
2013-01-14 08:39 EST, Jan Synacek
no flags Details | Diff

  None (edit)
Description Robert Scheck 2013-01-10 19:06:19 EST
Description of problem:
/usr/share/logwatch/scripts/services/secure:212 is currently:

  ( $ThisLine =~ /password check failed for user \([a-zA-Z]*\)/) or

Unfortunately this does not match our (system) users, which are "customer_01"
or "example_02" (of course without the "").

Version-Release number of selected component (if applicable):
logwatch-7.3.6-50.el6.noarch

How reproducible:
Everytime, see above and below.
  
Actual results:
Logwatch doesn't proper ignore "password check failed for user"

Expected results:
From my point of view, a proper fix for this could be:

  ( $ThisLine =~ /password check failed for user \(\S*\)/) or
Comment 2 Jan Synacek 2013-01-14 08:39:16 EST
Created attachment 678234 [details]
[Patch] handle usernames correctly
Comment 3 Robert Scheck 2013-01-18 05:08:38 EST
Patch looks basically fine to me, if manually applied
Comment 11 errata-xmlrpc 2013-09-10 09:40:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1247.html

Note You need to log in before you can comment on or make changes to this bug.