Bug 89422 - mkfifo sometimes fails to correctly set permissions
Summary: mkfifo sometimes fails to correctly set permissions
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: fileutils   
(Show other bugs)
Version: 2.1
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-22 20:16 UTC by Chad Talbott
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-28 09:47:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to modechange.c (1.71 KB, patch)
2003-04-22 20:19 UTC, Chad Talbott
no flags Details | Diff

Description Chad Talbott 2003-04-22 20:16:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
The permission that are set on a newly mkfifo'd fifo are incorrect in cases
where the permissions are set from the default user mask.  For example:

$ umask -S
u=rwx,g=rx,o=rx
$ mkfifo -m go=u regular_fifo
$ ls -l regular_fifo 
prw-rw-r--    1 root     root            0 Apr 22 13:07 regular_fifo

The correct permissions are prw-rw-rw-

I will attach a patch that corrects the problem.

Version-Release number of selected component (if applicable):
fileutils-4.1-4

How reproducible:
Always

Steps to Reproduce:
$ umask -S
u=rwx,g=rx,o=rx
$ mkfifo -m go=u regular_fifo

Actual Results:  $ ls -l regular_fifo 
prw-rw-r--    1 root     root            0 Apr 22 13:07 regular_fifo


Expected Results:  
The correct permissions are prw-rw-rw-


Additional info:

Comment 1 Chad Talbott 2003-04-22 20:19:29 UTC
Created attachment 91231 [details]
Patch to modechange.c

Comment 2 Tim Waugh 2003-04-24 14:32:50 UTC
Thanks.

Comment 3 Chad Talbott 2003-04-24 21:36:24 UTC
FWIW: Looks like this fix has appeared in the latest FSF version of fileutils
(now coreutils).


Note You need to log in before you can comment on or make changes to this bug.