Bug 89426 - Evolution will not consistently start
Evolution will not consistently start
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-22 16:24 EDT by scohen
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-14 20:14:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of `strace evolution` (192.26 KB, text/plain)
2003-04-23 19:56 EDT, scohen
no flags Details

  None (edit)
Description scohen 2003-04-22 16:24:33 EDT
Description of problem:
I have a fresh install of Redhat 9 with all available updates installed. 
Somtimes I can run evolution just fine, but most of the time I get the following
in a message box:

Application "wombat (process <some pid>) has crashed due to a fatal error.
(Segmentation fault).

If I click close I get the same error again.  Clicking close on this one yields:

Cannot initialize the Ximian Evolution shell: Configuration Database not found.

Trying to rerun it has the same effect, though sometimes it seems like I get
lucky and it runs fine.  I have tried all of the following to try to get it
running again, none of the seem to have any effect:

- Running killev
- Running oaf-slay
- Killing the gconf processes and the bonobo-activation-server process
- Deleting all the files in /tmp/orbit-<username> and restarting my X session
- Rebooting

If I try to run wombat at the command line I get:
]$ wombat
wombat-Message: Starting wombat
Wombat up and running

But when I run evolution the same thing happens and it kills the wombat I
started.  I have also tried creating a new user account.  This usually lets
evolution run the first few times I try but after a while it fails as well.

Version-Release number of selected component (if applicable):
evolution-1.2.2-5
oaf-0.6.10-5
bonobo-1.0.22-4
[If you need any others let me know]

How reproducible:
Happens pretty much every time I try to run evolution.  I have also at times
gotten similar errors from gnome-terminal and it will fail to load my color
preferences, but I haven't seen that for a while.
Comment 1 Havoc Pennington 2003-04-22 23:10:46 EDT
note that evolution uses bonobo-conf rather than gconf, so the config database
there isn't gconf (just so you don't waste time restarting it ;-))

I think this is in the evolution faq on ximian's web site but I'm not sure.
Comment 3 scohen 2003-04-23 19:54:24 EDT
I checked the Ximian FAQ and mailing lists before submitting this, none of those
suggestions help (I'm pretty sure if libraries weren't linking correctly or
directories were missing/not readable then evolution would never have run).  I
also submitted this as a bug in Gnome's Bugzilla under bonobo but they told me
it wasn't their issue.

I tried removing and reinstalling the evolution RPM just now.  That didn't help
either.  I've tried running evolution through strace to see what is failing to
open to cause the error but I couldn't find it.  I'll try again and also post
the trace, perhaps that will be useful.
Comment 4 scohen 2003-04-23 19:56:42 EDT
Created attachment 91264 [details]
Output of `strace evolution`
Comment 5 scohen 2003-04-23 20:32:29 EDT
In the strace output, toward the end, some reads from file descriptor 3 return
EAGAIN, meaning non-blocking I/O has been selected and no data was immediately
available for reading.  I'm not sure which file is fd 3, it looks like the last
thing to return 3 as a descriptor is a Unix socket:
socket(PF_UNIX, SOCK_STREAM, 0)         = 3

There seem to be previous successful reads and writes to that pipe, though, so
I'm not sure what that means.

Oh, and even when my user can't run evolution, it seems root can.  I'll try
running it as root and see if the same thing eventually happens.

By the way, if I run it as my user in a console, in addition the the dialog
boxes with errors I see the following returned (I assume on stderr):
(Killing old version of Wombat...)
(Cannot access Bonobo/ConfigDatabase, not upgrading configuration.)
        IDL:OAF/GeneralError:1.0
 
evolution-shell-WARNING **: Cannot access Bonobo/ConfigDatabase on wombat:
(IDL:OAF/GeneralError:1.0)
Comment 6 scohen 2003-04-25 01:11:56 EDT
Eventually the same thing does happen for root.
Comment 7 Jeremy Katz 2003-10-14 20:14:01 EDT
I've yet to reproduce this and it becomes a non-issue with evolution 1.4.5 in
rawhide (since the libraries in question are completely different and oaf is no
more)

Note You need to log in before you can comment on or make changes to this bug.