Bug 8943 - linuxconf skips entries in /etc/sysconfig/static-routes
linuxconf skips entries in /etc/sysconfig/static-routes
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-28 12:13 EST by furiorh
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 11:58:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description furiorh 2000-01-28 12:13:36 EST
We have a large LAN made up of non-contiguous blocks.
I have /etc/sysconfig/static-routes containing, among other things:
   eth0 net x.y.1.0    netmask 255.255.255.0
   eth0 net x.y.2.0    netmask 255.255.255.0
   eth0 net x.y.144.0  netmask 255.255.240.0
The system I am configuring now lives in x.y.1.0 and has
   DEVICE=eth0
   IPADDR=x.y.1.22
   NETMASK=255.255.255.0
   NETWORK=x.y.1.0
   BROADCAST=x.y.1.255
   ONBOOT=yes
in /etc/sysconfig/network-scripts/ifcfg-eth0.

The problem is that linuxconf does not install my other static routes
to eth0: it installs only the one where the machine lives on.
Disabling linuxconf (chmod u-x /bin/linuxconf) eliminates the problem:
the loop in the "else" part within
/etc/sysconfig/network-scripts/ifup-routes is exactly what I want,
and linuxconf seems to add some undesired intelligence.

furio ercolessi
Spin
Comment 1 Brent Fox 2002-06-05 11:54:28 EDT
Closing because we don't ship linuxconf anymore.

Note You need to log in before you can comment on or make changes to this bug.