Bug 89435 - service ip netmask of "None" causes "[ip]/None" in /etc/samba/smb.conf.sharename
Summary: service ip netmask of "None" causes "[ip]/None" in /etc/samba/smb.conf.sharename
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: clumanager (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-22 20:57 UTC by Hardy Merrill
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 15:22:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hardy Merrill 2003-04-22 20:57:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Using 'cluadmin' to add a service, you are prompted for ip address and netmask
information.  For 'netmask', you are allowed to specify 'None' - but doing that
causes this to appear in the /etc/samba/smb.conf.sharename file:

  interfaces = [ip]/None

When 'None' is specified as the netmask, the interfaces should look like this:

  interfaces = [ip]

with no '/None' tacked on.

Version-Release number of selected component (if applicable):
clumanager-1.0.19-2

How reproducible:
Always

Steps to Reproduce:
1. use cluadmin to add a service
2. add an ip address, and specify 'None' as the netmask
3. observe that the /etc/samba/smb.conf.sharename file ends up with
   an 'interfaces' value that looks like '[ip]/None'.  This is
   incorrect.
    

Actual Results:  When 'None' as specified as the netmask, the
/etc/samba/smb.conf.sharename should end up with an 'interfaces' value like
'[ip]' - with no '/None' tacked on.

Additional info:

Comment 1 Lon Hohberger 2003-04-28 18:19:48 UTC
Fix in CVS pool.  Will be in next erratum.

Comment 2 Suzanne Hillman 2003-10-03 15:22:51 UTC
Since U2 was in May, and the fix was submitted to CVS in late April, I'm going
to guess that this fix was in U2, and close this. If the problem was not
resolved, please reopen.


Note You need to log in before you can comment on or make changes to this bug.