Bug 894356 - spacewalk-schema-upgrade to provide general upgrade information and a prompt for db backup confirmation
spacewalk-schema-upgrade to provide general upgrade information and a prompt ...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: space19
  Show dependency treegraph
 
Reported: 2013-01-11 09:30 EST by Milan Zazrivec
Modified: 2013-03-06 13:34 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-06 13:34:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2013-01-11 09:30:50 EST
Description of problem:
To reflect on several customer issues & suggestions, spacewalk-schema-upgrade
command should be able to display general information on schema upgrades
as well as inform the user (or customer) to make sure a valid db backup exists.

Version-Release number of selected component (if applicable):
Satellite 5.5

How reproducible:
Always

Steps to Reproduce:
1. Run spacewalk-schema-upgrade for a satellite-schema upgrade
2. The command should give a general guidance on schema upgrades
3. The command should instruct to check whether a valid db backup exists
before commencing with the schema upgrade.
  
Actual results:
Not implemented.

Expected results:
Implemented.

Additional info:
N/A
Comment 1 Milan Zazrivec 2013-01-11 10:12:59 EST
spacewalk.git master: 13bc1a910851d1ee7ecaf04f908478b67e352c73
Comment 2 Stephen Herr 2013-03-01 12:07:00 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 3 Stephen Herr 2013-03-06 13:34:24 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19

Note You need to log in before you can comment on or make changes to this bug.