This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 894490 - version.h in version 3.7.1-2.fc18 devel package is zero-length
version.h in version 3.7.1-2.fc18 devel package is zero-length
Status: CLOSED DUPLICATE of bug 892373
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-11 16:13 EST by Mike Crawford
Modified: 2013-01-11 16:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 16:23:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Crawford 2013-01-11 16:13:00 EST
Description of problem:
version.h should define LINUX_VERSION_CODE and KERNEL_VERSION, but the file included in package kernel-devel-3.7.1-2.fc18.x86_64 is empty.

The file with the appropriate content was found in /lib/modules/3.7.1-2.fc17.x86_64/build/include/generated/uapi/linux/version.h

Version-Release number of selected component (if applicable):
3.7.1-2.fc18

How reproducible:
Static files within the package

Steps to Reproduce:
1. Install package
2. Attempt to use the symbols from include/linux/version.h

  
Actual results:
Error messages from symbols not being defined

Expected results:
Any module compilation requiring this file should work without error

Additional info:
Comment 1 Josh Boyer 2013-01-11 16:23:17 EST

*** This bug has been marked as a duplicate of bug 892373 ***

Note You need to log in before you can comment on or make changes to this bug.