Bug 894537 - gnome-terminal gets told "Refusing new client connection because the session is currently being shut down"
Summary: gnome-terminal gets told "Refusing new client connection because the session ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session
Version: 18
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-12 00:14 UTC by Linus Torvalds
Modified: 2013-03-16 01:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-16 01:45:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Linus Torvalds 2013-01-12 00:14:39 UTC
Description of problem:

 Opening a new gnome-terminal mostly takes about five seconds, even on a machine where it is supposed to be instantaneous.

This seems to be due to gnome-session returning "Refusing new client connection because the session is currently being shut down" string.

Starting gnome-terminal from another terminal shows this warning:

  ** (gnome-terminal:16713): WARNING **: Failed to connect to the session manager: IO error occured doing Protocol Setup on connection

which seems to happen after a five-second timeout *after* it got that "Refusing new client .." error.

Version-Release number of selected component (if applicable):

   GNOME Terminal 3.6.1
   gnome-session 3.6.2

both from current Fedora 18 (Spherical Cow), updated from a working Fedora 17 setup.

How reproducible:

  It seems to happen almost 100% of the time.

   I say "almost", because I think the *first* terminal of a session tends to open immediately.

Steps to Reproduce:
1. Try to open a new gnome-terminal more than once
2. Go for coffee
3. Come back to the terminal finally being open.
  
Actual results:

 Slow.

Expected results:

 Immediate terminal window (fast machine, lots of memory, good SSD).

Additional info:

Comment 1 Linus Torvalds 2013-01-15 02:57:10 UTC
This seems to be one of those annoying "F18 has new kernel configuration requirements" bugs.

Building my own kernel with the configuration that *used* to work, no longer does.

I did a "localmodconfig" and tried to figure our what the difference is, and the most likely one seems to be that F18 requires CONFIG_MEMCG, whereas F17 apparently never cared.

So I'm closing this as NOTABUG, and as being just due to annoying config dependencies.

Comment 2 Linus Torvalds 2013-01-26 06:11:55 UTC
Re-opening the bug, because it turns out that the kernel configuration thing was a red herring. It often works for a while, and then gnome-session for some reason starts thinking that the session is closing down.

I ran for a long time while strace'ing gnome-session to see what it was that triggered it, but when I traced it, it never started happening. Which makes me suspect that it's some race condition or other, and tracing it just makes it slow enough that it never happens.

Comment 3 Linus Torvalds 2013-01-26 06:15:00 UTC
Re-opening the bug, because it turns out that the kernel configuration thing was a red herring. It often works for a while, and then gnome-session for some reason starts thinking that the session is closing down.

I ran for a long time while strace'ing gnome-session to see what it was that triggered it, but when I traced it, it never started happening. Which makes me suspect that it's some race condition or other, and tracing it just makes it slow enough that it never happens.

Comment 4 Michael Chapman 2013-02-05 23:47:23 UTC
This occurs only if the session had been asked to shutdown but the shutdown was cancelled. gnome-session is not reverting to a state where it will accept new connections again.

It appears to be already reported upstream at https://bugzilla.gnome.org/show_bug.cgi?id=691513 .

Comment 5 Michael Chapman 2013-02-27 09:02:39 UTC
A patch to fix this was submitted through the linked GNOME bugzilla ticket. It's now been committed to upstream master:

http://git.gnome.org/browse/gnome-session/commit/?id=42356904ef974ca8376158dddd3d36f913f793a0

Any chance we could get this applied to F18's gnome-session-3.6.2?

Comment 6 Ray Strode [halfline] 2013-03-04 15:33:47 UTC
Jan says he's going to take care of the update for this.

Comment 7 Fedora Update System 2013-03-05 08:28:45 UTC
gnome-session-3.6.2-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-session-3.6.2-4.fc18

Comment 8 Fedora Update System 2013-03-05 23:24:43 UTC
Package gnome-session-3.6.2-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-session-3.6.2-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3446/gnome-session-3.6.2-4.fc18
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2013-03-16 01:45:27 UTC
gnome-session-3.6.2-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.