Bug 89468 - No network-installation via anaconda possible
Summary: No network-installation via anaconda possible
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-23 05:59 UTC by steigerwald
Modified: 2007-03-27 04:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 01:38:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the requested logfile (30.00 KB, text/plain)
2003-07-17 08:06 UTC, Patrick C. F. Ernzer
no flags Details
kickstart configuration file (2.57 KB, text/plain)
2003-08-21 10:41 UTC, Giuseppe Raimondi
no flags Details

Description steigerwald 2003-04-23 05:59:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1) Gecko/20020920
Netscape/7.0

Description of problem:
It is not possible to install RedHat 9 via network (kickstart) and nfs or http.

Using nfs you will get no error message, but on console 3 ( alt+f3)
there will be error message:  
failed to mount nfs source : ...
This will be a problem with RedHat 9. The same procedure will be ok, when i'm
installing RedHat 8.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot from an RedHat 9 Installation-CD
2.Try to install RH9 via:
linux text ks=nfs:......

    

Additional info:

Comment 1 steigerwald 2003-04-23 07:32:48 UTC
the following error messages will be displayed

using nfs:

url is x.x.x.x:/web/..../ks.cfg
ks location: nfs://x.x.x.x:/web/.../ks.cfg
failed to mount nfs source

using http:

ks location: http://x.x.x.x/linux/.../ks.cfg
transferring http://x.x.x.x//./linux/.../ks.cfg
failed to retrieve http://x.x.x.x///linux/.../ks.cfg

Comment 2 Michael Young 2003-04-23 11:08:28 UTC
Did the previous line talk about reverse lookup errors? We saw a problem where
if the IP address was resolved via DHCP such installs failed, but if it was
configured manually, it worked.

Comment 3 steigerwald 2003-05-05 12:49:21 UTC
there was no reverse lookup error.
with the same ks.cfg file and the same hardware is it possible
to install RedHat 8.0 without any errors !!!
This seem to be a problem of RedHat 9.

Comment 4 Michael Fulbright 2003-05-12 20:31:48 UTC
The following are lines I use almost daily for testing:

linux ks=http://<host>/<path>/ks.cfg

linux ks=nfs:<host>:/<path>/ks.cfg

Look at:

http://www.redhat.com/docs/manuals/linux/RHL-8.0-Manual/custom-guide/s1-kickstart2-startinginstall.html

Comment 5 Patrick C. F. Ernzer 2003-05-26 10:32:27 UTC
Had a call with the customer, here's more info:

manually installing by booting from CD1 with 'linux text askmethod" works like a
charm, their NFS server gives the machine access to the fully exploded tree and
installation is good.

their DHCP server will generate IPs as necessary and will push the new IPs to
the DNS every 15 minutes.

Booted off RHL 9 CD1 with "linux text
ks=nfs:10.184.166.80:/web/ezti/linux/redhat/ks90/ks.cfg", anaconda comes up and
asks for language selection.

in tty2, doing the following:

ifconfig shows eth0 (10.184.167.58) and lo.

mounting 10.184.166.80:/web/ezti/linux by hand from within tty2 works.

nslookup 10.184.166.80 = ezti80.wob.vw.vwg
nslookup ezti80.wob.vw.vwg = 10.184.166.80

nslookup 10.184.167.58 = UNKNOWN host

So, is this the problem? And if yes, why did it work with RHL 8.0

Comment 6 Michael Fulbright 2003-05-27 18:44:00 UTC
You need the 'askmethod' option or the CD will be automatically used as the
install source.

Comment 7 Michael Young 2003-05-29 14:13:03 UTC
I don't think your comment on "askmethod" is right for kickstart installs.
nfs kickstart installs work for me when booting from a CD without the
"askmethod" option, as the install uses whatever method is specified in the
kickstart file. The CD install only kicks in if the kickstart install fails
because the kickstart file is unavailable.

Comment 8 Michael Young 2003-05-29 14:21:33 UTC
Note there is a similar bug 90774 , where the problem seems to be somehow
related to lengthy negotiations between the network card and the router.

Comment 9 Patrick C. F. Ernzer 2003-06-11 09:11:50 UTC
Update from customer to Issue Tracker
[start]
The option askmethod during the installation wouldn't help.
[end]

Comment 10 Jeremy Katz 2003-07-14 22:29:39 UTC
Can you attach the /tmp/anaconda.log and /tmp/syslog from once you get to the
second stage after grabbing the ks.cfg failed?

Comment 11 Patrick C. F. Ernzer 2003-07-17 08:06:43 UTC
Created attachment 92975 [details]
the requested logfile

this was submitted to Issue Tracker. Attaching here for customer.

Comment 12 Giuseppe Raimondi 2003-08-21 10:41:58 UTC
Created attachment 93813 [details]
kickstart configuration file

uploaded in issue 21796 by the customer

Comment 13 Giuseppe Raimondi 2003-08-21 10:44:15 UTC
update from customer to IT#21796
it seems the same problem is visible also with AS 3 beta.

 It is noch possible to install Redhat as3 Beta via kickstart too.
the following steps i've done:
1. create an Redhat AS3 Install-CD
2. boot
3. start the installation by typing: linux ks=nfs:xxx.xxx.xxx.xxx:/[installpath]

Then I will get an error message "That directory could not be mounted from the
server"

I will get the same message when i try to install via "linux ks=floppy"

During this process there doesn't  appear any messages /var/log/messages !!!!

The configuration:
- PC ( should be installed with Redhat AS3)
- Installserver ( Redhat 8.0)
- NFS-Installation
- DHCP-Server ( Solaris 7/8 ?)

On console 4 there you can see an, that the DHCP-Servers has send in answer to
the dhcp-request from my pc.

 The manual installation via CD and nfs with the same client and server works 



Comment 14 Giuseppe Raimondi 2003-08-21 11:29:24 UTC
Customer tried an installation with a local kickstart file:

 The installation with a local (on floppy) ks.cfg will produce the same errors.


Comment 15 Giuseppe Raimondi 2003-08-21 13:31:23 UTC
Customer tried an installation with a local kickstart file:

 The installation with a local (on floppy) ks.cfg will produce the same errors.

Comment 16 Giuseppe Raimondi 2003-08-21 14:12:37 UTC
comment from customer

 I've tried the floppy installation again.
Now i've irgnored the error-message "That directory could not be mounted from
the server".
next steps:
- select dhcp settings for this client
- input of ip-adress und installation-directory of our installation-server
=> at this time a message  "rpc.mountd: authenticated mount request from
xxx.xxx.xxx.xxx" will apear in /var/log/messages
in our installationserver !!! and I can start with my installation... 

Comment 17 Giuseppe Raimondi 2003-08-22 10:50:25 UTC
latest comment:

I think i've found the "bug":

It is nessessary to use FQDN instead of IP-Adresses in RedHat 9  (or RedHat AS)
for booting via CDROM
(linux ks=nfs:ws.vw.de:/install) and within the kickstartfile ( nfs --server
ws.vw.de --dir /install) when you are
using anaconda.

Best regards

Andre Steigerwald


Comment 18 Jeremy Katz 2003-10-22 01:38:09 UTC
If your DHCP server doesn't set up your search/domain information, then yes, you
will have to either  use fqdn or ip.


Note You need to log in before you can comment on or make changes to this bug.