Bug 894689 - [ovirt-log-collector] Can not use log-collector due to certificate issues
[ovirt-log-collector] Can not use log-collector due to certificate issues
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector (Show other bugs)
3.2.0
x86_64 Linux
urgent Severity urgent
: ---
: 3.2.0
Assigned To: Kiril Nesenko
Ilanit Stein
integration
: Regression
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2013-01-13 03:32 EST by Kiril Nesenko
Modified: 2014-07-10 20:09 EDT (History)
11 users (show)

See Also:
Fixed In Version: rhevm-log-collector-3.2.0-0.0.master.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Previously, the naming convention in place for the certificate file used by rhevm-log-collector to ensure secure communications prevented the uploader from working correctly. The certificate file, formerly named engine_ca, is now called cert_file, and the rhevm-log-collector functions correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 16:08:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11024 None None None Never

  None (edit)
Description Kiril Nesenko 2013-01-13 03:32:08 EST
Description of problem:
Can not use log-collector due to certificate issues. 
the way optparse works is to first try and find an exact match of the param (that is to match "engine" with "engine"), and if there's no match, it will check whether "engine" could be an abbreviation of another param (that is there's only one parameter that begins with "engine") , and in this case "engine_ca" matches. This causes "engine_ca" param to get value of "engine" from the configuration file, and thus supply incorrect value to the API object creation. 

Fix is to replace "engine_ca" -> "ca_file"/"cert_file"/"certificate"


Version-Release number of selected component (if applicable):
rhevm-log-collector-3.1.0-10.el6ev.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Kiril Nesenko 2013-01-15 04:01:22 EST
Patch posted for review: http://gerrit.ovirt.org/#/c/11024/1
Comment 4 Ilanit Stein 2013-02-20 07:26:25 EST
Verified on sf7
Comment 5 Cheryn Tan 2013-04-09 00:26:41 EDT
This bug is currently attached to errata RHEA-2013:14554. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.

* Consequence: What happens when the bug presents.

* Fix: What was done to fix the bug.

* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks in advance.
Comment 6 errata-xmlrpc 2013-06-10 16:08:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0918.html

Note You need to log in before you can comment on or make changes to this bug.