Bug 894690 - [ovirt-image-uploader] Can not use image-uploader due to certificate issues
[ovirt-image-uploader] Can not use image-uploader due to certificate issues
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-image-uploader (Show other bugs)
3.2.0
x86_64 Linux
urgent Severity urgent
: ---
: 3.2.0
Assigned To: Kiril Nesenko
Ilanit Stein
integration
: Regression
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2013-01-13 03:36 EST by Kiril Nesenko
Modified: 2014-07-10 20:09 EDT (History)
11 users (show)

See Also:
Fixed In Version: rhevm-image-uploader-3.2.0-0.0.master.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Previously, the naming convention in place for the certificate file used by rhevm-image-uploader to ensure secure communications prevented the uploader from working correctly. The certificate file, formerly named engine_ca, is now called cert_file, and the rhevm-image-uploader functions correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 16:17:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11023 None None None Never

  None (edit)
Description Kiril Nesenko 2013-01-13 03:36:11 EST
Description of problem:
Can not use image-uploader due to certificate issues. 
the way optparse works is to first try and find an exact match of the param (that is to match "engine" with "engine"), and if there's no match, it will check whether "engine" could be an abbreviation of another param (that is there's only one parameter that begins with "engine") , and in this case "engine_ca" matches. This causes "engine_ca" param to get value of "engine" from the configuration file, and thus supply incorrect value to the API object creation. 

Fix is to replace "engine_ca" -> "ca_file"/"cert_file"/"certificate"


Version-Release number of selected component (if applicable):
rhevm-image-uploader-3.1.0-8.el6ev.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Kiril Nesenko 2013-01-15 04:01:01 EST
Patch posted for review: http://gerrit.ovirt.org/#/c/11023/1
Comment 4 Ilanit Stein 2013-02-20 07:32:26 EST
Verified on sf7:
root@lilach-rhel ~]# engine-image-uploader --engine lilach-rhel.qa.lab.tlv.redhat.com list
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to abort): 
ERROR: There are no export storage domains.
Comment 5 errata-xmlrpc 2013-06-10 16:17:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0920.html

Note You need to log in before you can comment on or make changes to this bug.