Bug 89477 - rpm throws db4 errors depending on user running it
rpm throws db4 errors depending on user running it
Status: CLOSED DUPLICATE of bug 88720
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2003-04-23 08:11 EDT by Thomas Vander Stichele
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:52:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Thomas Vander Stichele 2003-04-23 08:11:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I've written mach, a chroot builder.  It bootstraps the least amount of packages
necessary to get apt-get running, and then forces a consistency update.

I have observed that running rpm --root (path to chroot) -qa can give errors
when run sudo or as root, while it works fine as user.  I've been able to
reproduce this on two Red Hat 9 (non-updated) machines, so it should be

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Get mach from http://thomas.apestaart.org/projects/mach/
2. Read the README and get the packages to install redhat 9
3. run "make rpm-build" in dist/redhat-9-i386
4. install libvorbis by doing
   sudo /usr/sbin/chroot /usr/local/mach/root
   apt-get install libvorbis
   (this triggers install as well)
5. leave the chroot and run
   sudo /bin/rpm --root /usr/local/mach/root -qa

Actual Results:  rpm -qa throws an error, stopping at unzip
last bit of output:
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page
not found

Expected Results:  when running /bin/rpm --root /usr/local/mach/root -qa, no
errors are thrown, and the whole package list is returned.

As you can see, the first package returned after unzip is the newly installed
libvorbis rpm.

Additional info:

Running rpm as root instead of sudo root also gives the same error.

Sorry to make it some effort to reproduce using mach, but I've taken some time
to get to the easiest way to reproduce this with the least amount of factors
affecting the install.

Hope this helps us both :)
Comment 1 Barry K. Nathan 2003-04-24 16:50:09 EDT
Hmmm. This *might* be a dupe of bug 88720.
Comment 2 Jeff Johnson 2003-06-25 11:24:40 EDT

*** This bug has been marked as a duplicate of 88720 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:52:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.