Bug 894933 - False positive in validation warning for missing/unexpected variables
False positive in validation warning for missing/unexpected variables
Status: CLOSED WONTFIX
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Damian Jansen
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-13 22:39 EST by Hedda Peters
Modified: 2014-03-06 00:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-06 00:55:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2013-01-13 22:39:25 EST
Description of problem:
The following msgid/msgstr causes a false positive in the validation warnings:

msgid: "... which allows curly brackets (<literal>{</literal> and <literal>}</literal>) to be used..."

msgstr: "... geschweifte Klammern (<literal>{</literal> und <literal>}</literal>) erlaubt..."


Steps to Reproduce:
See URL provided in next (private) comment.
  
Actual results:
Validation warnings: Missing variable: {</literal> and <literal>}
Unexpected variable: {</literal> und <literal>} as soon as you translate "and".

Expected results:
No validation warning, "and" should be translatable

Additional info:
This seems like a rather rare constellation of tags/brackets and doesn't pose a big problem or anything. Low impact/priority.
Comment 3 David Mason 2013-04-30 22:47:14 EDT
Note: Comment 1 and Comment 2 are just links to an example row on a non-public server. They are hidden to prevent frustration trying to follow the links from outside the VPN, which won't work.
Comment 4 David Mason 2013-04-30 22:51:17 EDT
This warning is caused by the Java Variables Validator, which may not be appropriate to run against this project. If Java variables aren't used in this project, the appropriate action here would be to deactivate that particular validator for the project.
Comment 5 Damian Jansen 2014-03-06 00:55:19 EST
Closing because:
- minor issue
- seems to be a difficult fix for the value gained
- rare occurrence
- there's a "workaround" (indicated above)

Note You need to log in before you can comment on or make changes to this bug.