Bug 89499 - Bad xemacs documentation
Bad xemacs documentation
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Jay Turner
file:///usr/share/xemacs/xemacs-packa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-23 11:47 EDT by Christopher Wong
Modified: 2015-01-07 19:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-26 04:06:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Wong 2003-04-23 11:47:31 EDT
From Bugzilla Helper:
User-Agent: Opera/7.10 (Linux 2.4.20-9 i686; U)  [en]

Description of problem:
The JDE documentation is busted. The links for the JDE user's guide table of 
contents (given in the URL), all point to the same place. Trying to read the JDE 
users' guide doc within xemacs results in the error "Wrong type argument: 
char-or-string-p, 8482".

Version-Release number of selected component (if applicable):
xemacs-21.4.12-6

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:
Comment 1 Jens Petersen 2003-04-23 22:09:18 EDT
Works fine for me.

Fire up a new xemacs session

% xemacs -q

Type

  M-x jde-mode

From the menubar choose

  JDE -> Help -> JDEE Users Guide

and the documentation appears in mozilla.
Of course the sidebar needs the jdk plugin to work,
and admittedly the links to the JDE homepage seems stale and
the links to the source code aren't right, but otherwise it displays
fine for me?
Comment 2 Jens Petersen 2003-04-24 07:45:03 EDT
The links to the source files in the main page should get fixed
in the next package build, however the link in the jar file on the toc
is harder to fix since the java source doesn't seen to be include if I'm
not mistaken.
Comment 3 Christopher Wong 2003-04-24 11:19:44 EDT
You could call up the JDE docs within XEmacs fine because you set your browser 
to be Mozilla. My XEmacs is set up to run W3, and bombs out as I described when 
I try to call up the JDE docs.

The sidebar should not need Java to work. If you run, say, Konqueror with Java 
disabled you will see contents links as ordinary HTML. This is because they ARE 
ordinary HTML: they are plain vanilla HREFs. The problem is that jde-ug-toc.
html's links are broken: they point nowhere. Here is a sample:

<td><a href="jde-ug-content.html#" target="content">Introduction</a>
</td></tr><tr>
<td><a href="jde-ug-content.html#" target="content">Registering and Selecting a 
JDK</a></td></tr>tr>
<td><a href="jde-ug-content.html#" target="content">Editing Java Source 
Files</a></td></tr>

All the JDE User's Guide links point to "jde-ug-content.html#". That makes them 
useless. Contrast with the JDEBug user's Guide sidebar source.
Comment 4 Jens Petersen 2003-04-25 08:50:48 EDT
I'll fix the broken section links in the JDE User Guide in the next
package build.

As to the problem with w3 - I'm afraid w3 contains too many bugs to be
maintainable - so it is basically unsupported.  If you really want to
display html inside xemacs, then I recommend using w3m-el-xemacs, which
uses w3m as its engine, and hence is also much quicker than w3.

[I'll close the bug when the jde update is built.]
Comment 5 Jens Petersen 2003-04-25 19:41:32 EDT
Links should be fixed in xemacs-21.4.12-10.
Comment 6 Jens Petersen 2003-04-26 04:06:41 EDT
I reported this upstream too, so it should get fixed in
the xemacs-packages sumo too one day.

Note You need to log in before you can comment on or make changes to this bug.