Bug 894998 - spacewalk-backend fails to build on Fedora 19 due spacewalk-pylint errors
spacewalk-backend fails to build on Fedora 19 due spacewalk-pylint errors
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: space19
  Show dependency treegraph
 
Reported: 2013-01-14 04:30 EST by Miroslav Suchý
Modified: 2013-03-06 13:34 EST (History)
1 user (show)

See Also:
Fixed In Version: spacewalk-backend-1.9.22-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-06 13:34:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2013-01-14 04:30:49 EST
Description of problem:
spacewal;k-backend fails to build on Fedora 19 due spacewalk-pylint errors

From:
http://kojipkgs.fedoraproject.org//work/tasks/6476/4866476/build.log

************* Module spacewalk.common.fileutils
E1101:175,4:rhn_popen: Instance of 'Popen' has no 'stdin' member
E1101:182,20:rhn_popen: Instance of 'Popen' has no 'stdout' member
E1101:182,43:rhn_popen: Instance of 'Popen' has no 'stderr' member
E1101:188,17:rhn_popen: Instance of 'Popen' has no 'poll' member
************* Module spacewalk.common.rhn_deb
R0924: 30,0:deb_Header: Badly implemented Container, implements __getitem__ but not __delitem__, __len__, __setitem__
************* Module spacewalk.common.rhn_mpm
W1401:225,0: Anomalous backslash in string: '\0'. String constant might be missing an r prefix.
W1401:226,0: Anomalous backslash in string: '\0'. String constant might be missing an r prefix.
R0924: 98,0:MPM_Header: Badly implemented Container, implements __delitem__, __getitem__, __setitem__ but not __len__
************* Module spacewalk.common.rhn_rpm
R0924: 65,0:RPM_Header: Badly implemented Container, implements __getitem__ but not __delitem__, __len__, __setitem__


Version-Release number of selected component (if applicable):
spacewalk-backend-1.8.85-1.fc19.src.rpm


Steps to Reproduce:
1. build spacewalk-backend in Fedora Koji
Comment 1 Jan Pazdziora 2013-02-04 05:45:29 EST
Scratch build of spacewalk-backend-1.9.23-1 shows the Spacewalk nightly package builds fine: http://koji.fedoraproject.org/koji/taskinfo?taskID=4926624
Comment 2 Miroslav Suchý 2013-02-04 06:15:11 EST
For the record - Fixed in commits:
0edfc1579efbdb8cf6a19a99339368a17d931aa8
c73ffdd68cb6d48330f88eba0745ba2a8434d1a5
974d3d4c9c851c8454e3aa44efbe14a3a64b8664
f896639d71daf786a3fb85eb0a1bf0a0b00334df
fbff981103d1545ac53b11e943c79516acf8266c

Thanks for fixing.
Comment 3 Stephen Herr 2013-03-01 12:07:20 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 4 Stephen Herr 2013-03-06 13:34:44 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19

Note You need to log in before you can comment on or make changes to this bug.