Bug 895004 - warning: Client has n monitors, but only 1 qxl devices found
Summary: warning: Client has n monitors, but only 1 qxl devices found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-vdagent
Version: 6.4
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Hans de Goede
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 921155
TreeView+ depends on / blocked
 
Reported: 2013-01-14 09:44 UTC by Tomas Jamrisko
Modified: 2013-11-21 06:24 UTC (History)
5 users (show)

Fixed In Version: spice-vdagent-0.12.0-5.el6
Doc Type: Bug Fix
Doc Text:
The vdagent agent logged warning messages when multiple monitors were used on a single qxl device. With this update, the agent does not log a warning when there are more monitors than qxl-devs.
Clone Of:
Environment:
Last Closed: 2013-11-21 06:24:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1560 normal SHIPPED_LIVE spice-vdagent bug fix and enhancement update 2013-11-20 21:40:19 UTC

Description Tomas Jamrisko 2013-01-14 09:44:02 UTC
Description of problem:
vdagent logs a warning message, when client has multiple displays open and one qxl device -- which is normal as of 6.4

Version-Release number of selected component (if applicable):
spice-vdagent-0.12.0-4.el6.i686


How reproducible:
Always

Steps to Reproduce:
1. Open a second display channel
2. Check the log
  
Actual results:
You'll find there the mentioned warning

Comment 2 RHEL Product and Program Management 2013-01-18 06:47:43 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 Hans de Goede 2013-01-24 12:02:01 UTC
This is fixed by this upstream commit:
http://cgit.freedesktop.org/spice/linux/vd_agent/commit/?id=1fc816764b6db66c671ffa936ee024a481d88bb4

Comment 4 Hans de Goede 2013-03-09 19:24:20 UTC
I'm doing a new build for 6.5: spice-vdagent-0.12.0-5.el6.

This new build brings in a whole set of interdependent patches from upstream to fix bug 881020, this includes the fix for this -> moving to MODIFIED.

Comment 8 errata-xmlrpc 2013-11-21 06:24:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1560.html


Note You need to log in before you can comment on or make changes to this bug.