Bug 895037 - perl-PPIx-Regexp-0.029 is available
Summary: perl-PPIx-Regexp-0.029 is available
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-PPIx-Regexp
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-14 10:51 UTC by Upstream Release Monitoring
Modified: 2013-01-30 00:50 UTC (History)
2 users (show)

Fixed In Version: perl-PPIx-Regexp-0.029-1.fc19
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-30 00:48:08 UTC


Attachments (Terms of Use)

Description Upstream Release Monitoring 2013-01-14 10:51:07 UTC
Latest upstream release: 0.029
Current version in Fedora Rawhide: 0.028
URL: http://search.cpan.org/dist/PPIx-Regexp/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Ralf Corsepius 2013-01-18 07:22:24 UTC
Would it be possible to also upgrade to 0.029 for f17 and f18?

Perl-MinimumVersion >= 1.32 would require it, from what I gather from Perl-MinimumVersion's ChangeLog, due to PPIx-Regexp < 0.029 suffering from bugs, which affected Perl-MinimumVersion.

Comment 2 Petr Pisar 2013-01-18 09:14:07 UTC
F18 has 0.28, F17 has 0.25 now, PPIx-Regexp changes:

0.029		2013-01-14	T. R. Wyant
  No changes from 0.028_02.

0.028_02	2012-12-31	T. R. Wyant
  Add method unescaped_content() to PPIx::Regexp::Element().
  Rewrite the tokenizing code in PPIx::Regexp::Token::GroupType and
    offspring to use regular expressions specific to the regexp
    delimiter, and escaping only that delimiter. Thanks again to
    Alexandr Ciornii for finding more of these.

0.028_01	2012-12-20	T. R. Wyant
  Fix mis-parse of /(\?|I)/ as a branch reset (it's really an
    alternation). There may be more of these lurking. Thanks to Alexandr
    Ciornii for finding this one.
  Add options -files and -objectify to eg/predump.

0.028		2012-06-06	T. R. Wyant
  Replace all uses of YAML::Any with YAML, since they come in the same
    distro, and YAML does not suffer from deprecation warnings.

0.027		2012-05-28	T. R. Wyant
  Eliminate unescaped literal "{" characters in regexps in
    PPIx::Regexp::Token::Backreference and
    PPIx::Regexp::Token::CharClass::Simple. These are deprecated in 5.17.0.

0.026		2012-02-24	T. R. Wyant
  Add support for \F (fold case), added in 5.15.8.


I will do the rebase hoping the tokenizer rewrite has not introduced new bugs.

Comment 3 Fedora Update System 2013-01-18 09:26:55 UTC
perl-PPIx-Regexp-0.029-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-PPIx-Regexp-0.029-1.fc18

Comment 4 Fedora Update System 2013-01-18 09:28:29 UTC
perl-PPIx-Regexp-0.029-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/perl-PPIx-Regexp-0.029-1.fc17

Comment 5 Fedora Update System 2013-01-20 03:18:07 UTC
Package perl-PPIx-Regexp-0.029-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-PPIx-Regexp-0.029-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1095/perl-PPIx-Regexp-0.029-1.fc18
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-01-30 00:48:10 UTC
perl-PPIx-Regexp-0.029-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2013-01-30 00:50:55 UTC
perl-PPIx-Regexp-0.029-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.