Bug 89513 - ps no longer displays process parameters.
ps no longer displays process parameters.
Status: CLOSED DUPLICATE of bug 87638
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Brian Brock
N/A
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-23 14:07 EDT by Jim Zimmerman
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is my current ps output. (4.19 KB, text/plain)
2003-04-23 14:10 EDT, Jim Zimmerman
no flags Details

  None (edit)
Description Jim Zimmerman 2003-04-23 14:07:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2)
Gecko/20030208 Netscape/7.02

Description of problem:
When issuing a ps command with any numerous options, it is not possible to
display the process parameters for all processes.  In particular, processes that
are displayed in brackets are no longer displayed with their full parameters. 
The parameters are only displayed for some processes.  This worked before I
upgraded the kernel to 2.4.18-27.7xsmp.  It looks like this happens in Redhat 8
too.  I have plenty of memory and really doubt that all of the processes in
brackets are swapped out to disk.  The particular processes I have been
interested in are [_mprosrv].  I can get the process to display without the
brackets (i.e. ps -A), but still do not see the parameters.


Version-Release number of selected component (if applicable):
procps-2.0.7-11

How reproducible:
Always

Steps to Reproduce:
1.ps auxwww 
2.
3.
    

Actual Results:  I see many processes displayed in brackets with no parameters.

Expected Results:  See more processes displayed without brackets and with
parameters.

Additional info:

This is what the display look like before the kernel upgrade.

[root@la-app2 root]# cat ps
USER       PID %CPU %MEM   VSZ  RSS TTY      STAT START   TIME COMMAND
root         1  0.0  0.0  1404  460 ?        S     2002   0:06 init [3]
root         2  0.0  0.0     0    0 ?        SW    2002   0:00 [keventd]
root         3  0.0  0.0     0    0 ?        SWN   2002   0:00 [ksoftirqd_CPU0]
root         4  0.1  0.0     0    0 ?        SW    2002 232:24 [kswapd]
root         5  0.0  0.0     0    0 ?        SW    2002   0:33 [kreclaimd]
root         6  0.0  0.0     0    0 ?        SW    2002   6:09 [bdflush]
root         7  0.0  0.0     0    0 ?        SW    2002   0:29 [kupdated]
root         8  0.0  0.0     0    0 ?        SW<   2002   0:00 [mdrecoveryd]
root        16  0.0  0.0     0    0 ?        SW    2002   0:34 [kjournald]
root       135  0.0  0.0     0    0 ?        SW    2002   6:37 [kjournald]
root       136  0.0  0.0     0    0 ?        SW    2002   0:17 [kjournald]
lp         793  0.0  0.0  2580  988 ?        S     2002   0:00 lpd Waiting
xfs        945  0.0  0.1  5412 4128 ?        S     2002   0:00 xfs -droppriv -daemon
daemon     963  0.0  0.0  1448  552 ?        S     2002   0:00 /usr/sbin/atd
root      1008  0.0  0.0  2340 1088 tty1     S     2002   0:00 login -- root    
root      1009  0.0  0.0  2340 1092 tty2     S     2002   0:00 login -- root    
root      1010  0.0  0.0  1388  436 tty3     S     2002   0:00 /sbin/mingetty tty3
root      1011  0.0  0.0  1388  436 tty4     S     2002   0:00 /sbin/mingetty tty4
root      1012  0.0  0.0  1388  436 tty5     S     2002   0:00 /sbin/mingetty tty5
root      1013  0.0  0.0  1388  436 tty6     S     2002   0:00 /sbin/mingetty tty6
root      7086  0.0  0.0  2676 1276 ?        S     2002   0:01 /usr/sbin/sshd
root     28738  0.0  0.0  2524 1344 tty1     S     2002   0:00 -bash
root     21840  0.0  0.0  1476  584 ?        S    Feb06   0:02 syslogd -m 0
root     21845  0.0  0.0  1988 1104 ?        S    Feb06   0:00 klogd -2
root     22446  0.0  0.0  1604  696 ?        S    Feb06   0:11 crond
root     23063  0.0  0.5 12880 11064 ?       S    Mar04   0:32
/usr/apps/dlc/cur/bin/_mprosrv -pf apclear.pf
root     23097  0.0  0.0 13044 1904 ?        S    Mar04   0:04
/usr/apps/dlc/cur/bin/_mprosrv -m1 /opt/apodb/apclear -N TCP -Nd /dev/tcp -hs 0
-Mm 16000 -cpinternal iso8859-1 -cpstream iso8859-1 -cpterm iso8859-1 -cpcase
basic -cpcoll basic -S apclearsv
root     25566  0.0  0.0  1648  616 ?        S    Mar10   0:01 rhnsd --interval 120
root     25703  0.0  0.0  5536 2040 ?        S    Mar10   0:04 sendmail:
accepting connections
root     25739  0.0  0.0  2172  928 ?        S    Mar10   0:07 xinetd -stayalive
-reuse -pidfile /var/run/xinetd.pid
mpsys     1898  0.0  0.1  6656 2372 ?        SN   Mar17   1:40
/opt/apps/dlc/9.1c11/bin/_progres -1 -b -p /home/mpsys/authserv.p -T /tmp
root      4180  0.0  0.0  3736 2168 ?        S    Mar18   0:00 /usr/sbin/sshd
jzimmer   4183  0.0  0.0  2504 1328 pts/3    S    Mar18   0:00 -bash
root      4232  0.0  0.0  2372 1032 pts/3    S    Mar18   0:00 su -
root      4236  0.0  0.0  2532 1368 pts/3    S    Mar18   0:04 -bash
root      5659  0.0  0.0  2280  924 ?        S    Mar18   0:00
/opt/apps/dlc/cur/bin/_proapbk -pf /opt/apodb/appsrv/appsrv.pf
root      6244  0.0  0.0  4600  868 ?        S    Mar18   0:00 _proapsv -pf
/opt/apodb/appsrv/appsrv.pf
root      6249  0.0  0.0  4600  868 ?        S    Mar18   0:00 _proapsv -pf
/opt/apodb/appsrv/appsrv.pf
root      7865  0.0  0.0  3692 2052 ?        S    07:15   0:00 /usr/sbin/sshd
root      7867  0.0  0.0  2520 1344 pts/0    S    07:15   0:00 -bash
root      7923  0.1  0.0  2528 1352 tty2     S    07:16   0:00 -bash
root      7978  0.0  0.0  2664  736 tty2     R    07:16   0:00 ps auxwwww
[root@la-app2 root]#
Comment 1 Jim Zimmerman 2003-04-23 14:10:50 EDT
Created attachment 91255 [details]
Here is my current ps output.

Here is my current ps display, with memory information.

[root@la-app2 root]# ps auxwwww
USER	   PID %CPU %MEM   VSZ	RSS TTY      STAT START   TIME COMMAND
root	     1	0.0  0.0  1404	472 ?	     S	  Mar19   0:13 init [3]
root	     2	0.0  0.0     0	  0 ?	     SW   Mar19   0:00 [migration_CPU0]

root	     3	0.0  0.0     0	  0 ?	     SW   Mar19   0:00 [migration_CPU1]

root	     4	0.0  0.0     0	  0 ?	     SW   Mar19   0:00 [keventd]
root	     5	0.0  0.0     0	  0 ?	     SWN  Mar19   0:00 [ksoftirqd_CPU0]

root	     6	0.0  0.0     0	  0 ?	     SWN  Mar19   0:00 [ksoftirqd_CPU1]

root	     7	0.0  0.0     0	  0 ?	     SW   Mar19   1:05 [kswapd]
root	     8	0.0  0.0     0	  0 ?	     SW   Mar19   0:00 [bdflush]
root	     9	0.0  0.0     0	  0 ?	     SW   Mar19   0:07 [kupdated]
root	    10	0.0  0.0     0	  0 ?	     SW   Mar19   0:00 [mdrecoveryd]
root	    18	0.0  0.0     0	  0 ?	     SW   Mar19   0:13 [kjournald]
root	   137	0.0  0.0     0	  0 ?	     SW   Mar19   0:28 [kjournald]
root	   138	0.0  0.0     0	  0 ?	     SW   Mar19   0:08 [kjournald]
root	   682	0.0  0.0  1476	584 ?	     S	  Mar19   0:03 syslogd -m 0
root	   687	0.0  0.0  2192 1224 ?	     S	  Mar19   0:00 klogd -2
root	   761	0.0  0.0  2676 1276 ?	     S	  Mar19   0:02 /usr/sbin/sshd
root	   795	0.0  0.0  2232	968 ?	     S	  Mar19   0:02 xinetd
-stayalive -reuse -pidfile /var/run/xinetd.pid
lp	   819	0.0  0.0  2580	988 ?	     S	  Mar19   0:00 [lpd]
root	   867	0.0  0.0  1608	700 ?	     S	  Mar19   0:03 crond
xfs	   941	0.0  0.1  5176 3848 ?	     S	  Mar19   0:00 [xfs]
daemon	   959	0.0  0.0  1452	556 ?	     S	  Mar19   0:00 [atd]
root	   980	0.0  0.0  1648	616 ?	     S	  Mar19   0:00 rhnsd --interval
120
root	   986	0.0  0.0  1392	440 tty2     S	  Mar19   0:00 /sbin/mingetty
tty2
root	   987	0.0  0.0  1392	440 tty3     S	  Mar19   0:00 /sbin/mingetty
tty3
root	   988	0.0  0.0  1392	440 tty4     S	  Mar19   0:00 /sbin/mingetty
tty4
root	   989	0.0  0.0  1392	440 tty5     S	  Mar19   0:00 /sbin/mingetty
tty5
root	   990	0.0  0.0  1392	440 tty6     S	  Mar19   0:00 /sbin/mingetty
tty6
root	  2057	0.0  0.5 12880 11064 ?	     S	  Mar19   3:59 [_mprosrv]
root	  2064	0.0  0.0  2288	932 ?	     S	  Mar19   0:09 [_proapbk]
root	 10216	0.0  0.1 13040 2564 ?	     S	  Mar20   1:21 [_mprosrv]
mpsys	 13636	0.0  0.1  6656 2372 ?	     SN   Mar27   0:53 [_progres]
root	 16720	0.0  0.0  5544 2060 ?	     S	  Apr09   0:14 sendmail:
accepting connections
root	 16751	0.0  0.0  1392	440 tty1     S	  Apr21   0:00 /sbin/mingetty
tty1
root	 21878	0.0  0.0  3696 2112 ?	     S	  Apr22   0:00 /usr/sbin/sshd
jzimmer  21879	0.0  0.0  2516 1352 pts/0    S	  Apr22   0:00 -bash
root	 21963	0.0  0.0  2372 1024 pts/0    S	  Apr22   0:00 [su]
root	 21964	0.0  0.0  2520 1352 pts/0    S	  Apr22   0:00 -bash
root	 26475	0.0  0.0  4596	868 ?	     S	  09:37   0:00 [_proapsv]
root	 26489	0.0  0.0  4592	864 ?	     S	  09:39   0:00 [_proapsv]
root	 26708	0.0  0.0  2932 1736 pts/0    S	  10:48   0:00 ssh bast3
root	 26710	0.0  0.0  3696 2040 ?	     R	  10:49   0:00 /usr/sbin/sshd
root	 26711	0.0  0.0  2520 1340 pts/1    S	  10:49   0:00 -bash
root	 26785	0.0  0.0  2648	720 pts/1    R	  10:54   0:00 ps auxwwww
[root@la-app2 root]#


[root@la-app2 root]# free -m
	     total	 used	    free     shared    buffers	   cached
Mem:	      2142	 1236	     905	  0	   108	      997
-/+ buffers/cache:	  130	    2012
Swap:	      2047	    0	    2047

[root@la-app2 root]# vmstat 5
   procs		      memory	swap	      io     system	    cpu

 r  b  w   swpd   free	 buff  cache  si  so	bi    bo   in	 cs  us  sy  id

 0  0  0      0 927736 111696 1021456	0   0	  0	3    2	   3   0   0  
0
 0  0  0      0 927736 111704 1021456	0   0	  0    10  515	  30   0   0
100
 0  0  0      0 927736 111704 1021456	0   0	  0	2  516	  29   0   0
100
 0  0  0      0 927736 111704 1021456	0   0	  0	2  515	  29   0   0
100
 0  0  0      0 927736 111704 1021456	0   0	  0	2  516	  29   0   0
100
Comment 2 Alexander Larsson 2003-04-24 11:50:17 EDT
This looks like a dup of bug 87638

*** This bug has been marked as a duplicate of 87638 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:52:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.