Bug 89519 - rpm hangs followed by rpm segfault on -qa, --rebuildb,
Summary: rpm hangs followed by rpm segfault on -qa, --rebuildb,
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-23 18:49 UTC by Val Schmidt
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-28 17:41:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Val Schmidt 2003-04-23 18:49:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
This is a RH8.0 systems with a "complete" installation.  

I was experiencing similar symptoms to previous bugs in which rpm would hang on
-Uvh or Fvh.  I killed the rpm process each time and only later learned that I
also needed to ensure the db lock files were removed for proper operation.

However, I have since done that...

[root@kokua i386]# rm /var/lib/rpm/__db*
rm: remove regular file `/var/lib/rpm/__db.001'? y
rm: remove regular file `/var/lib/rpm/__db.002'? y
rm: remove regular file `/var/lib/rpm/__db.003'? y

...and now any operation with rpm results in a segmentation fault. For example:

 rpm -vv --rebuilddb
Segmentation fault

 rpm -vv -qa
Segmentation fault

An strace can be seen at http://www.ldeo.columbia.edu/~vschmidt/rpmqatrace 
if that's any help.


Version-Release number of selected component (if applicable):
rpm-4.1-1.06

How reproducible:
Always

Steps to Reproduce:
1.rpm -qa  is all that's required
2.
3.
    

Additional info:

Although I see the problem every time, I'm not sure what steps were required to
get me here - so in that sense I haven't been able to reproduce it. I'm grasping
at straws to understand what causes these kinds of errors.

Comment 1 Jeff Johnson 2003-04-23 19:03:09 UTC
Can you give me a pointer (i.e. URL, attachments won't work)
to a tarball of your database
    cd /var/lib
    tar xzvf /tmp/rpmdb-89519.tar.gz rpm
and I'll take a look? Thanks.


Comment 2 Val Schmidt 2003-04-23 20:13:33 UTC
Yes.

/var/lib/rpm tar'd and zipped and can be found at

www.ldeo.columbia.edu/~vschmidt/rpmdb.tar.gz



Comment 3 Jeff Johnson 2003-04-24 18:51:55 UTC
OK, your database looks fine, all header signatures verify,
so something else is going on.

The strace indicates segfault before reaching main in rpm,
which seems to point at something other than rpm as the cause.

Do any rpm commads work? Try
    rpm -V glibc kernel
possibly other commands as well, and tell me what works or
not, please.

Comment 4 Val Schmidt 2003-04-28 17:41:05 UTC
It turns out the cause of this didn't have anything to do with rpm directly.  

Early on, rpm (4.1.1) had hung and had to be killed. It appears that some, but 
not all, of the glib* rpms were updated during that process.  

This seems to have caused the ensuing segmentation faults with rpm and (other 
processes on the system it would turn out).  

I force updated the glib* rpms from the RH8.0 basic distro with
rpm -Uvh --force glib*

The segmentation faults are gone.

OF NOTE: There were two errors when executing the above (in a trigger script 
and a post install script).  Although this may bite me in the bottom, at first 
look, they appear to be inconsequential.  To be sure, I've executed an rpm -
qa --info > rpmlonglist, and when I have time I'll try to figure out if my 
forced install has broken any dependancies.

Thanks for everyone's help.

-Val


Note You need to log in before you can comment on or make changes to this bug.