Bug 895214 - Update wavextract import of PIL for F19 switch to Pillow
Update wavextract import of PIL for F19 switch to Pillow
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wavextract (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PILLOW
  Show dependency treegraph
 
Reported: 2013-01-14 15:51 EST by Stephen Gallagher
Modified: 2013-01-16 08:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-15 13:15:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Change imports of PIL Library so they'll work with pillow (399 bytes, patch)
2013-01-14 15:51 EST, Stephen Gallagher
no flags Details | Diff

  None (edit)
Description Stephen Gallagher 2013-01-14 15:51:37 EST
Created attachment 678426 [details]
Change imports of PIL Library so they'll work with pillow

Description of problem:

Fedora 19 is switching from using python-imaging (PIL) to python-pillow.  This is mostly backwards compatible but importing the python-imaging relevant libraries is undergoing a change.  In PIL, the libraries could either be imported like this:

import Image

or like this:

from PIL import Image

In python-pillow (and thus, Fedora19+), only the latter will work.  I've grepped the sources of wavextract and found a few import statements that need to be updated.  Patch attached to fix those.  Patch should be upstreamable as PIL supports both the old and new forms of the import.

Version-Release number of selected component (if applicable):

wavextract-1.0.0-8
Comment 1 Gwyn Ciesla 2013-01-15 11:27:05 EST
Should this require python-imaging still, or python-pillow?
Comment 2 Gwyn Ciesla 2013-01-15 13:15:40 EST
Updated, using python-imaging.
Comment 3 Stephen Gallagher 2013-01-16 08:33:32 EST
Sorry for the late response. Python-imaging is fine, since it's a drop-in replacement.

Note You need to log in before you can comment on or make changes to this bug.