Bug 89522 - GRUB should use "map" for Windows on non-primary partition
GRUB should use "map" for Windows on non-primary partition
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-23 15:35 EDT by Steve Hall
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-23 15:39:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Hall 2003-04-23 15:35:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Description of problem:

Windows 95 (probably many newer) can not boot from a slave hard drive,
even when particularly specifying, i.e., "rootnoverify (hd1,0)". But
GRUB can easily be configured to work around this using the "map"
argument:

  # load Windows on a second (slave) hard drive
  title Windows
      map (hd1) (hd0)
      rootnoverify (hd0,0)
      chainloader +1

Read more here:
  http://www.gnu.org/software/grub/grub-faq.en.html#q10

This should be the default setup when a vfat filesystem is detected on
any drive other than the primary. (Note GRUB properly detected the
filesystem and location, and even passed off to the OS, Windows just
failed to boot from there.)


Version-Release number of selected component (if applicable):
(default, not sure)

How reproducible:
Always

Steps to Reproduce:
Occurs with any default RH9 install with a Windows 95 (newer?) OS on a
non-primary drive partition.

Additional info:

It seems likely this would be an acceptable even on a later version of Windows
that *was* able to handle booting from non-primary. I'm categorizing as
Severity:High because it completely disables the OS. (*skips opportunity to make
jokes*)
Comment 1 Jeremy Katz 2003-04-23 15:39:18 EDT
Depends entirely on BIOS and version of Windows.  Newer versions of Windows are
able to boot from a slave hard drive fine -- I know I did it with Windows 98
many years ago.

Note You need to log in before you can comment on or make changes to this bug.