Bug 89523 - There is a version of ddd that compiles with modern tools and has bash debugging
There is a version of ddd that compiles with modern tools and has bash debugging
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ddd (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
http://bashdb.sourceforge.net
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-23 15:45 EDT by Rocky Bernstein
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-05 06:27:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rocky Bernstein 2003-04-23 15:45:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
This is not really a bug per se. I noticed Yellowdog has a version of ddd that
uses either old source or is heavily patched. Daniel Schepler and I have made
extensive changes to DDD to get this to compile under modern tools (flex, g++,
autotools). It also has bash debugging support. 

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Rocky Bernstein 2003-04-23 15:49:42 EDT
I meant to write RedHat rather than Yellowdog above.
Comment 2 Ngo Than 2003-04-29 10:47:21 EDT
it would be great if you send the changes
Comment 3 Rocky Bernstein 2003-04-30 02:48:39 EDT
File releases are at
http://sourceforge.net/project/showfiles.php?group_id=61395 
scroll down for DDD. CVS access info is at
http://sourceforge.net/cvs/?group_id=61395

the module name is ddd. 

There is a new ddd maintainer (The old one hasn't done anything in 2 years) and
got word that everything here will be merged into older ddd without change. When
that's done, I'll remove the above. Got word on this a week ago, but no one as
yet has done any work. Also I understand from Daniel Schelper that CVS listed
abouve has a couple more changes that are not in the 3.3.5 release. 
Comment 4 Ngo Than 2003-04-30 05:17:32 EDT
Is ddd-3.3.5 the stable release version? I don't have seen any announce to 3.3.5
on Ddd mailing list!

As i know, 3.3.1 is the latest stable release since 2 years, and Andreas Zeller
does not have time to maintain ddd anymore.

Do you know who is the current ddd maintainer?

Thanks
Comment 5 Ngo Than 2003-05-05 06:27:43 EDT
there is 3.3.5 in rawhide now.

Note You need to log in before you can comment on or make changes to this bug.