Bug 895310 - [abrt] ruby-1.9.3.362-24.fc17: rb_bug: Process /usr/bin/ruby was killed by signal 6 (SIGABRT)
[abrt] ruby-1.9.3.362-24.fc17: rb_bug: Process /usr/bin/ruby was killed by si...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
abrt_hash:99230aa317771942fab3500f584...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-14 22:01 EST by Dan Callaghan
Modified: 2013-02-03 22:26 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-03 22:26:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace from abrt (53.64 KB, text/plain)
2013-01-15 20:20 EST, Dan Callaghan
no flags Details

  None (edit)
Description Dan Callaghan 2013-01-14 22:01:34 EST
Description of problem:
Happens reproducibly when starting sup (mail client). Was working fine with ruby-1.9.3.327-19.fc17.x86_64. I do have some compiled gems in ~/.gems, I will try rebuilding those.

Version-Release number of selected component:
ruby-1.9.3.362-24.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        ruby -I~/work/sup/lib /home/dcallagh/work/sup/bin/sup
crash_function: rb_bug
kernel:         3.6.11-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #2 rb_bug at error.c:284
: #3 sigsegv at signal.c:609
: #5 search_method at vm_method.c:374
: #6 rb_method_entry_get_without_cache at vm_method.c:393
: #7 rb_method_entry at vm_method.c:426
: #8 vm_method_search at vm_insnhelper.c:1375
: #10 vm_exec_core at insns.def:1902
: #11 vm_exec at vm.c:1227
: #12 invoke_block_from_c at vm.c:631
: #13 rb_vm_invoke_proc at vm.c:677

Potential duplicate bug: 704606
Comment 1 Dan Callaghan 2013-01-14 22:14:57 EST
Looks like abrt failed to upload all the extra info, but I do have it here in case any of it helps.

Also this is the ruby crash handler output:

/home/dcallagh/work/sup/lib/sup/modes/thread-index-mode.rb:660: [BUG] Segmentation fault
ruby 1.9.3p362 (2012-12-25 revision 38607) [x86_64-linux]

-- Control frame information -----------------------------------------------
c:0004 p:0027 s:0012 b:0010 l:0000f8 d:000009 BLOCK  /home/dcallagh/work/sup/lib/sup/modes/thread-index-mode.rb:660
c:0003 p:0007 s:0007 b:0007 l:0021c0 d:000006 BLOCK  /home/dcallagh/work/sup/lib/sup.rb:80
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:---- s:0002 b:0002 l:000001 d:000001 TOP   

-- Ruby level backtrace information ----------------------------------------
/home/dcallagh/work/sup/lib/sup.rb:80:in `block in reporting_thread'
/home/dcallagh/work/sup/lib/sup/modes/thread-index-mode.rb:660:in `block in load_n_threads_background'

-- C level backtrace information -------------------------------------------
/lib64/libruby.so.1.9(+0x156239) [0x7f1684912239] ../sysdeps/x86_64/multiarch/strcpy-ssse3.S:1447
/lib64/libruby.so.1.9(+0x57de9) [0x7f1684813de9] vfscanf.c:771
/lib64/libruby.so.1.9(rb_bug+0xb3) [0x7f16848145d3] vfscanf.c:2620
/lib64/libruby.so.1.9(+0xf790f) [0x7f16848b390f] sgetsgent.c:66
/lib64/libpthread.so.0(+0xefe0) [0x7f16845aefe0] ../nptl/sysdeps/pthread/funlockfile.c:30
/lib64/libruby.so.1.9(+0x140f68) [0x7f16848fcf68] ../sysdeps/x86_64/multiarch/memcpy-ssse3.S:1931
/lib64/libruby.so.1.9(+0x1431b1) [0x7f16848ff1b1] ../sysdeps/x86_64/multiarch/memcpy-ssse3.S:1425
/lib64/libruby.so.1.9(+0x14aa3e) [0x7f1684906a3e] ../sysdeps/x86_64/multiarch/memcpy-ssse3-back.S:765
/lib64/libruby.so.1.9(+0x14b890) [0x7f1684907890] ../sysdeps/x86_64/multiarch/memcpy-ssse3-back.S:1572
/lib64/libruby.so.1.9(+0x14c48d) [0x7f168490848d] ../sysdeps/x86_64/multiarch/memcpy-ssse3-back.S:2440
/lib64/libruby.so.1.9(+0x15c002) [0x7f1684918002] ../sysdeps/x86_64/multiarch/memcmp-sse4.S:801
/lib64/libruby.so.1.9(+0x15c0de) [0x7f16849180de] ../sysdeps/x86_64/multiarch/memcmp-sse4.S:1201
/lib64/libpthread.so.0(+0x7d14) [0x7f16845a7d14] pthread_create.c:309
/lib64/libc.so.6(clone+0x6d) [0x7f168399c68d] ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

[the rest omitted]
Comment 2 Dan Callaghan 2013-01-15 17:51:13 EST
I was using ruby-1.9.3.327-19.fc17.x86_64 previously, so I guess this problem happened sometime between p327 and p362. p327 isn't in updates anymore but I downgraded to ruby-1.9.3.194-10.1.fc17.x86_64 and the problem goes away. I have rebuilt my gems in ~/.gem against the various versions, it makes no difference so I don't think that is an issue.

When I get some spare time I will see if I can narrow the crash down to a simpler reproducer than "run my copy of sup".
Comment 3 Mamoru TASAKA 2013-01-15 20:13:21 EST
Can you generate gdb backtrace for this?
Comment 4 Dan Callaghan 2013-01-15 20:20:02 EST
Created attachment 679207 [details]
backtrace from abrt
Comment 5 Mamoru TASAKA 2013-01-16 04:24:24 EST
Looks like rb_vm_invoke_proc (and the function called by rb_vm_invoke_proc) does something wrong - _MAYBE_ due to the same reason on the bug 895173 (bug on rb_vm_make_env_object <- rb_vm_make_proc)
Comment 6 Mamoru TASAKA 2013-01-16 10:09:17 EST
The comming -25 *may* or *may not* fix this issue. Anyway please try.
Comment 7 Dan Callaghan 2013-01-16 16:50:11 EST
Yes I can confirm that ruby-1.9.3.362-25.fc17.x86_64 fixes the problem. Thanks!
Comment 8 Mamoru TASAKA 2013-01-16 19:56:18 EST
Thank you for confirmation!
Comment 9 Mamoru TASAKA 2013-02-03 22:26:21 EST
Closing. Thank you for reporting.

Note You need to log in before you can comment on or make changes to this bug.