Bug 895374 - timedatectl unable to set RTC local flag
timedatectl unable to set RTC local flag
Status: CLOSED DUPLICATE of bug 881577
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-15 01:47 EST by vvs
Modified: 2013-01-15 06:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-15 06:16:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vvs 2013-01-15 01:47:26 EST
Description of problem:

While trying to set RTC local flag I've got AVC denial. Looks like it doesn't allow to create a temporary file in /etc. timedatectl changes /etc/adjtime to store RTC local flag there. Apparently it creates a temporary file there.

Version-Release number of selected component (if applicable):

selinux-policy-targeted-3.11.1-66.fc18.noarch

How reproducible:

Always

Steps to Reproduce:
1. timedatectl set-local-rtc [0|1]
  
Actual results:

type=AVC msg=audit(1358231397.603:79): avc:  denied  { create } for  pid=1413 comm="systemd-timedat" name=".adjtimedVsHEL" scontext=system_u:system_r:gnomeclock_t:s0 tcontext=system_u:object_r:etc_t:s0 tclass=file

Expected results:

It should work

Additional info:
Comment 1 Miroslav Grepl 2013-01-15 06:16:27 EST

*** This bug has been marked as a duplicate of bug 881577 ***

Note You need to log in before you can comment on or make changes to this bug.