Bug 89543 - logwatch fails to read /var/log/messages in redhat 8.0
logwatch fails to read /var/log/messages in redhat 8.0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: logwatch (Show other bugs)
8.0
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-23 22:46 EDT by Andrew Neel
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-10 12:22:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Neel 2003-04-23 22:46:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:
        Logwatch scans a copy of /var/log/messages (see below) and attempts
pipes a filtered output into the script called 'kernel' This script should
process the input by cat->onlyservice->removerheaders->kernel which would print
out data on the system logs. Howerver, the same code (provided by the redhat
install) performs a cat->removerheaders->onlyservice->kernel. This produces no
error but also no useful information. Redhat 8.0 uses the same logwatch.pl
source version as in the 7.3 series but not the same perl version. I believe
that the version of perl is the ultimate cause but have not been able to locate
a specific root cause. Additionally, this package is version 2.6 while the
latest version from the maintainers is 4.3.2-1.

        <clip from a 'logwatch.pl --print --debug=10'>
        ( /bin/cat /tmp/logwatch.XXJbNb15/messages  |
/etc/log.d/scripts/shared/removeheaders '' |
/etc/log.d/scripts/shared/onlyservice 'kernel' |
/etc/log.d/scripts/services/kernel) 2>&1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.'logwatch.pl --print --debug=10'
2.
3.
    

Actual Results:  the contents of the /var/log/messages are read incorrectly and
a NO report is generated based on the content. Notably, it looks like one or two
one-offs still work. Those being cron and samba.


Expected Results:  the contents of the /var/log/messages are read and a NO
report is generated based on the content.


Additional info:
Comment 1 Elliot Lee 2003-07-10 12:22:19 EDT
The latest RHL version has 4.3.x

Note You need to log in before you can comment on or make changes to this bug.