Bug 8955 - sndconfig ignores noprobe and noautoconf switches
Summary: sndconfig ignores noprobe and noautoconf switches
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-29 00:22 UTC by bourdeau
Modified: 2014-03-17 02:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-31 05:15:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bourdeau 2000-01-29 00:22:16 UTC
I am unable to configure my sound card under RH Linux 6.1
due to the fact that sndconfig will not obey
the --noprobe and --noautoconf  (may have latter switch
mislabeled here, but I got it right when I used sndconfig)
switches.

First sndconfig says that the probe and autoconf have
been disabled, but then it goes ahead and probes.

This would not be a problem if the probe worked right, but
it does not. It SAYS it found an AUREAL Vortex card, but I
have a Turtle Beach Montego card. Since it says the AUREAL
card is not supported, it bails out and I'm no where. I'm
sure I could get around this if I understood the output of
isapnp and how to use it, but I don't.

PC Speaker works fine.

Platform: Dell XPS R450 running Intel Pentium II.

Comment 1 bourdeau 2000-01-30 18:34:59 UTC
Some addition info. I did discover that my Turtle Beach Montego II card
may indeed be fairly detected as an Aureal card. However, it supports
SBPro emulation, and I'd be perfectly happy if I could only use
the SBPro capabilities. I attempted to manually load the sb and sound
modules directly with modprobe using all the same parameter settings
as I use in Windows.

Comment 2 Bill Nottingham 2000-01-31 05:15:59 UTC
The --noprobe --noautoconfig problem with PCI cards has been fixed
in the sndconfig currently in Raw Hide, and yes, the Turtle Beach
Montego is a Vortex based card.

The problem with the SBPro emulation is that it's done by
the Windows drivers, not in hardware. You *may* be able
to get it to work by loading the drivers in DOS/Windows
and then warm booting into linux using loadlin or something
similar, but there's no guarantee that that will work. Your
best bet is to wait for drivers to become available; if you're
willing to use closed source drivers, there are ones available
from http://linux.aureal.com/.

Comment 3 bourdeau 2000-02-03 03:11:59 UTC
I downloaded the Aureal drivers mentioned above, compiled them and
installed them.  I am now able to utilize my TBS Montego II card
successfully. Thanks.


Note You need to log in before you can comment on or make changes to this bug.