Bug 89553 - mailman 2.1 needs site list.
mailman 2.1 needs site list.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mailman (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-24 06:11 EDT by David Woodhouse
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-24 10:55:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2003-04-24 06:11:11 EDT
Description of problem:
As of Mailman 2.1, a 'site list' is required, from which admin requests appear
to originate. When upgrading a previous Mailman setup, this site list is not
created and no indication is given that such is required. The 'INSTALL' file
containing this information isn't even included in the RPM.

The absence of the site list causes sender verification to fail, and hence all
outgoing administrative requests fail to be delivered.

Either the RPM post-install script should create this list if it doesn't already
exist, or some indication should be given to the site administrator that it's
required.
Comment 1 John Dennis 2003-04-24 10:55:20 EDT
The file /usr/share/doc/mailman-2.1.1/INSTALL.REDHAT contains the following:

    - Create a "site-wide" mailing list (Note: this must be done
      before starting the mailman daemon). This is the one that
      password reminders will appear to come from.  Usually this
      should be the "mailman" mailing list, but if you need to change
      this, be sure to change the MAILMAN_SITE_LIST variable in
      mm_cfg.py (see below).

          % /var/mailman/bin/newlist mailman

By the way, the reason this is not done in the RPM install is because there are
some manual installation tasks that have to be performed before newlist will
work correctly.

Note You need to log in before you can comment on or make changes to this bug.