Bug 895544 - maven-compiler-plugin: LICENSE and NOTICE files are not installed
Summary: maven-compiler-plugin: LICENSE and NOTICE files are not installed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: maven-compiler-plugin
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mikolaj Izdebski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE-Legal 895545
TreeView+ depends on / blocked
 
Reported: 2013-01-15 13:49 UTC by Mikolaj Izdebski
Modified: 2013-03-13 13:06 UTC (History)
3 users (show)

Fixed In Version: 3.0-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 895545 (view as bug list)
Environment:
Last Closed: 2013-03-13 13:06:56 UTC


Attachments (Terms of Use)

Description Mikolaj Izdebski 2013-01-15 13:49:44 UTC
Description of problem:
maven-compiler-plugin must install LICENSE and NOTICE files to comply with upstream licensing terms as well as Fedora guidelines.

Version-Release number of selected component (if applicable):
2.5.1-2

Additional info:
See packaging guidelines [1] and licensing guidelines [2].

[1] http://fedoraproject.org/wiki/Packaging:Guidelines
[2] http://fedoraproject.org/wiki/Packaging:LicensingGuidelines

Comment 1 Mikolaj Izdebski 2013-03-05 16:36:35 UTC
Fixed in maven-compiler-plugin-3.0-1

Comment 2 Mikolaj Izdebski 2013-03-13 13:06:56 UTC
I believe that this bug is fixed in maven-compiler-plugin-3.0-2,
which is available in Fedora 19, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=400046


Note You need to log in before you can comment on or make changes to this bug.