Bug 895745 - Failure to properly resize window
Summary: Failure to properly resize window
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 19
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-15 22:17 UTC by KitchM
Modified: 2016-12-01 00:43 UTC (History)
10 users (show)

Fixed In Version: gnome-abrt-0.3.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-15 00:53:42 UTC
Type: Bug


Attachments (Terms of Use)
Window still runs off screen in Fedora 19 (284.54 KB, image/png)
2013-08-06 15:27 UTC, KitchM
no flags Details

Description KitchM 2013-01-15 22:17:58 UTC
Description of problem:
When processing a report, the pop up window fails to line wrap and keep itself within the desktop limits.

Version-Release number of selected component (if applicable):
2.0.18

How reproducible:
In use

Steps to Reproduce:
1. Open RBRT
2. Report a report
3. Show log
4. If the lines of process are too long, they will open the window width to a size that runs off screen.
  
Actual results:
Bad

Expected results:
Proper window sizing controls

Additional info:

Comment 1 KitchM 2013-05-15 04:21:18 UTC
Fedora 18 also has this problem.  There is no proper line wrap.

Comment 2 Jakub Filak 2013-08-06 13:26:54 UTC
Thank you for the bug report. I guess this was a bug in gtk3, because I run kde-4.10, gnome-3.9 and gtk3-3.8.2 and I'm no longer able to reproduce this unwanted behaviour but source codes have not changed in a way which could affect this behaviour. 

If you have time to update your system and re-test, please do so and report the results here.

Comment 3 KitchM 2013-08-06 15:27:45 UTC
Created attachment 783378 [details]
Window still runs off screen in Fedora 19

Comment 4 KitchM 2013-08-06 15:29:20 UTC
Thanks for your help.  Window is still too big for screen in 19 with all latest updates thru today.

Comment 5 Jakub Filak 2013-08-07 08:04:53 UTC
Thank you for your prompt reply. I don't remember what is your desktop environment and what is your default screen size? I need to know it because I want to reproduce this unwanted behaviour on my machine.

Comment 6 KitchM 2013-08-07 17:42:45 UTC
Fedora 19 with Xfce 4.10.1 at 1024x768 on large home theater monitor.

Comment 7 Jakub Filak 2013-08-08 14:42:39 UTC
Thanks! I've finally figured out that the root cause are the warning messages and not the log lines.

Fixed in upstream git:
commit bfe206a3584cb553948f87b80f39efd740135dd0
Author: Jakub Filak <jfilak@redhat.com>
Date:   Thu Aug 8 16:10:46 2013 +0200

    report-gtk: use wrapped text for warning labels
    
    Warning texts were designed to fit into window size but their width
    depends on used font properties. Therefore we have to make text
    wrapped in order to not resize window.
    
    Closes rhbz#895745
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Richard Marko <rmarko@fedoraproject.org>

Comment 8 KitchM 2013-08-08 15:48:36 UTC
Thank you.

Comment 9 Fedora Update System 2013-09-13 13:08:52 UTC
gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19

Comment 10 Fedora Update System 2013-09-14 02:38:54 UTC
Package gnome-abrt-0.3.1-1.fc19, abrt-2.1.7-1.fc19, libreport-2.1.7-1.fc19, satyr-0.9-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-0.3.1-1.fc19 abrt-2.1.7-1.fc19 libreport-2.1.7-1.fc19 satyr-0.9-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16707/gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2013-09-15 00:53:42 UTC
gnome-abrt-0.3.1-1.fc19, abrt-2.1.7-1.fc19, libreport-2.1.7-1.fc19, satyr-0.9-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.