Bug 895752 - Cannot Install with Anaconda; Continue Button in screen for language selection does nothing
Cannot Install with Anaconda; Continue Button in screen for language selectio...
Status: CLOSED DUPLICATE of bug 893892
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-15 17:57 EST by chrys87
Modified: 2013-01-16 08:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-16 08:57:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/anaconda-tb-* (296.57 KB, text/plain)
2013-01-16 04:30 EST, Jann
no flags Details

  None (edit)
Description chrys87 2013-01-15 17:57:40 EST
Description of problem:
Hi,
I Try to install fedora 18 on my Samsung NF210. After boot the live cd, anaconda pops up (asking install or only try). If i try to install to harddisk -> a screen comes up where i have to select my language -> german (but the problem happens with all languages). Click to Continue/next (german -> weiter). nothing happens.it seems an permission problem dbus/network? The output is something like exception in AnanetworkThread and permission denied dbus. I cant write the log because its my other pc.

Version-Release number of selected component (if applicable):
18

How reproducible:
Try to install on samsung nf210 (maybe hardwarespecific)

Steps to Reproduce:
1. Boot Live  Cd an log in
2. Klick install to harddisk
3. Choose a language and klick next/continue/weiter button
  
Actual results:
Nothing happens

Expected results:
Installation Process
Comment 1 Jann 2013-01-16 03:03:22 EST
I have the same problem: It seems to be wireless related somehow

Description of problem:

The (live-cd) installer won't go passed the language selection screen when continue is pressed, regarding the choice of language. The problem disappears when the wifi-adapter is disabled/unplugged.

Version-Release number of selected component (if applicable):

anaconda 18.37.11 for Fedora 18 

How reproducible:

Reproducible

Steps to Reproduce:
On my laptop (Lenovo x301) there is a hardware wifi switch (on the back).

Case A:
1. if I boot with the wifi on, 
2. lauch the installer (either with the on login presented button) or with /usr/bin/liveinst)
3. Press continue --> nothing seems to happen

Case B:
1. if I boot with the wifi off, 
2. lauch the installer
3. Press continue --> everything seems ok
  
Additional info:
See also forum thread: http://www.forums.fedoraforum.org/showthread.php?t=287532

Case A (wifi on) throws these errors to the terminal:

[liveuser@localhost ~]$ /usr/bin/liveinst 
localuser:root being added to access control list
Starting installer, one moment...
anaconda 18.37.11 for Fedora 18 started.
Exception in thread AnaNetworkThread:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/threading.py", line 551, in __bootstrap_inner
    self.run()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 95, in run
    sys.excepthook(*sys.exc_info())
  File "/usr/lib/python2.7/site-packages/meh/handler.py", line 162, in <lambda>
    sys.excepthook = lambda ty, value, tb: self.handleException((ty, value, tb), obj)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/exception.py", line 82, in handleException
    (ty, value, tb), obj)
  File "/usr/lib/python2.7/site-packages/meh/handler.py", line 108, in handleException
    win = self.intf.mainExceptionWindow(str(self.exn), self.exnText)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 188, in mainExceptionWindow
    lightbox = AnacondaWidgets.lb_show_over(self._currentAction.window)
AttributeError: 'NoneType' object has no attribute 'window'


(anaconda:2298): Gtk-CRITICAL **: gtk_tree_model_filter_get_path: assertion `GTK_TREE_MODEL_FILTER (model)->priv->stamp == iter->stamp' failed

(anaconda:2298): Gtk-WARNING **: Overriding tab label for notebook
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 77, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 287, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 73, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 234, in _on_continue_clicked
    nextAction = self._instantiateAction(self._actions[1])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 77, in _instantiateAction
    obj = actionClass(self.data, self.storage, self.payload, self.instclass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1091, in __init__
    self.network_control_box.hostname = self.data.network.hostname
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 960, in hostname
    self.entry_hostname.set_text(value)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 47, in function
    return info.invoke(*args, **kwargs)
TypeError: Argument 1 does not allow None as a value

(anaconda:2298): Gtk-WARNING **: Overriding tab label for notebook
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 77, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 287, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 73, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 234, in _on_continue_clicked
    nextAction = self._instantiateAction(self._actions[1])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 77, in _instantiateAction
    obj = actionClass(self.data, self.storage, self.payload, self.instclass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1091, in __init__
    self.network_control_box.hostname = self.data.network.hostname
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 960, in hostname
    self.entry_hostname.set_text(value)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 47, in function
    return info.invoke(*args, **kwargs)
TypeError: Argument 1 does not allow None as a value
Comment 2 Radek Vykydal 2013-01-16 04:16:09 EST
This seems like a duplicate of bug #893892 (wwan device is involved?), I'd like to see /tmp/anaconda-tb* to be sure.

You can check a fix from https://bugzilla.redhat.com/show_bug.cgi?id=893892#c10.
Comment 3 Jann 2013-01-16 04:30:28 EST
Created attachment 679429 [details]
/tmp/anaconda-tb-*

the requested /tmp/anaconda-tb-*
Comment 4 Radek Vykydal 2013-01-16 04:35:31 EST
Jann, your case is really a dupe of #893992.
Comment 5 Jann 2013-01-16 04:42:23 EST
That's solved then, maybe a good idea to add this bug to:
https://fedoraproject.org/wiki/Common_F18_bugs
Comment 6 Radek Vykydal 2013-01-16 08:57:27 EST
(In reply to comment #5)
> That's solved then, maybe a good idea to add this bug to:
> https://fedoraproject.org/wiki/Common_F18_bugs

True, I'm handling it in the original #893892.

*** This bug has been marked as a duplicate of bug 893892 ***

Note You need to log in before you can comment on or make changes to this bug.