Bug 895766 - IndexError: list index out of range
Summary: IndexError: list index out of range
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e0fe4d931382743eb356cfbf520...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-16 00:29 UTC by Grzegorz Witkowski
Modified: 2013-05-18 04:55 UTC (History)
5 users (show)

Fixed In Version: pykickstart-1.99.31-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-18 04:55:11 UTC


Attachments (Terms of Use)
File: anaconda-tb (530.22 KB, text/plain)
2013-01-16 00:29 UTC, Grzegorz Witkowski
no flags Details
File: anaconda.log (11.80 KB, text/plain)
2013-01-16 00:29 UTC, Grzegorz Witkowski
no flags Details
File: environ (777 bytes, text/plain)
2013-01-16 00:29 UTC, Grzegorz Witkowski
no flags Details
File: ifcfg.log (568 bytes, text/plain)
2013-01-16 00:30 UTC, Grzegorz Witkowski
no flags Details
File: packaging.log (163.06 KB, text/plain)
2013-01-16 00:30 UTC, Grzegorz Witkowski
no flags Details
File: program.log (19.96 KB, text/plain)
2013-01-16 00:30 UTC, Grzegorz Witkowski
no flags Details
File: storage.log (106.34 KB, text/plain)
2013-01-16 00:30 UTC, Grzegorz Witkowski
no flags Details
File: syslog (65.49 KB, text/plain)
2013-01-16 00:30 UTC, Grzegorz Witkowski
no flags Details

Description Grzegorz Witkowski 2013-01-16 00:29:43 UTC
Description of problem:
In Fedora 18 installation I selected a disk for installation and set the passphrase to encrypt the disk. When I saw a warning that my current keybord is US, I went back to keyboard selection and removed US keybord. Polish(Polish) was first, English(UK) second and English(US) third - removed, so only PL and UK left with PL in first place. Went back to disk selection, selected the same disk, selected that I want to encrypt the disk and clicked Continue button and got the error.
The following was filed automatically by anaconda:
anaconda 18.37.11 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/keyboard.py", line 502, in get_current_layout_name
    return groups_names[state.group]
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/passphrase.py", line 83, in refresh
    keymap_name = xkl_wrapper.get_current_layout_name()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/passphrase.py", line 100, in run
    self.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 634, in run_lightbox_dialog
    rc = dialog.run()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 711, in on_continue_clicked
    rc = self.run_lightbox_dialog(dialog)
IndexError: list index out of range

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2018\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.6.10-4.fc18.x86_64
other involved packages: 
package:        anaconda-18.37.11
product:        Fedora
release:        Cannot get release name.
type:           libreport
version:        18

Comment 1 Grzegorz Witkowski 2013-01-16 00:29:54 UTC
Created attachment 679184 [details]
File: anaconda-tb

Comment 2 Grzegorz Witkowski 2013-01-16 00:29:57 UTC
Created attachment 679185 [details]
File: anaconda.log

Comment 3 Grzegorz Witkowski 2013-01-16 00:29:59 UTC
Created attachment 679186 [details]
File: environ

Comment 4 Grzegorz Witkowski 2013-01-16 00:30:01 UTC
Created attachment 679187 [details]
File: ifcfg.log

Comment 5 Grzegorz Witkowski 2013-01-16 00:30:04 UTC
Created attachment 679188 [details]
File: packaging.log

Comment 6 Grzegorz Witkowski 2013-01-16 00:30:07 UTC
Created attachment 679189 [details]
File: program.log

Comment 7 Grzegorz Witkowski 2013-01-16 00:30:10 UTC
Created attachment 679190 [details]
File: storage.log

Comment 8 Grzegorz Witkowski 2013-01-16 00:30:13 UTC
Created attachment 679191 [details]
File: syslog

Comment 9 Vratislav Podzimek 2013-02-12 15:56:25 UTC
Patch sent to anaconda-patches.

Comment 10 Adam Williamson 2013-05-12 17:00:01 UTC
The behaviour of the keyboard spoke and Installation Destination spoke have changed somewhat since F18 so it's not possible to follow the original reproduction path precisely. I tried to get as close as I can, and could not reproduce this bug. However, I found the patch for this:

https://lists.fedorahosted.org/pipermail/anaconda-patches/2013-February/003038.html

As near as I can tell, that whole patch set wasn't explicitly acked on the list, but the "Remove debugging print" change was committed soon after. The big LayoutIndicator patch was re-submitted in April and then acked and committed in May. But this patch never seems to have been re-submitted or committed.

Setting back to ASSIGNED to attract Vratislav's attention, Vratislav, it looks like you should re-submit this patch for review?

Comment 11 Adam Williamson 2013-05-12 17:00:27 UTC
Er, I forgot to note above that I checked the git log and went and eyeballed the relevant file - pyanaconda/keyboard.py - and this change is definitely not in it.

Comment 12 Vratislav Podzimek 2013-05-13 13:32:02 UTC
(In reply to comment #10)
> The behaviour of the keyboard spoke and Installation Destination spoke have
> changed somewhat since F18 so it's not possible to follow the original
> reproduction path precisely. I tried to get as close as I can, and could not
> reproduce this bug. However, I found the patch for this:
> 
> https://lists.fedorahosted.org/pipermail/anaconda-patches/2013-February/
> 003038.html
> 
> As near as I can tell, that whole patch set wasn't explicitly acked on the
> list, but the "Remove debugging print" change was committed soon after. The
> big LayoutIndicator patch was re-submitted in April and then acked and
> committed in May. But this patch never seems to have been re-submitted or
> committed.
> 
> Setting back to ASSIGNED to attract Vratislav's attention, Vratislav, it
> looks like you should re-submit this patch for review?
Good catch, Adam! The code no longer uses the affected function, so I'm removing it completely in the patch I've just sent to anaconda-patches.

Comment 13 Fedora Update System 2013-05-15 22:25:22 UTC
anaconda-19.27-1.fc19, pykickstart-1.99.31-1.fc19, python-blivet-0.14-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.27-1.fc19

Comment 14 Fedora Update System 2013-05-16 05:21:45 UTC
Package anaconda-19.27-1.fc19, pykickstart-1.99.31-1.fc19, python-blivet-0.14-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.27-1.fc19 pykickstart-1.99.31-1.fc19 python-blivet-0.14-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.27-1.fc19
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2013-05-17 22:19:15 UTC
Package pykickstart-1.99.31-1.fc19, anaconda-19.28-1.fc19, python-blivet-0.14-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.31-1.fc19 anaconda-19.28-1.fc19 python-blivet-0.14-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.28-1.fc19
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2013-05-18 04:55:11 UTC
pykickstart-1.99.31-1.fc19, anaconda-19.28-1.fc19, python-blivet-0.14-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.