Bug 895815 - Gdm does not come up because of missing mdmonitor-takeover.service file
Gdm does not come up because of missing mdmonitor-takeover.service file
Status: CLOSED DUPLICATE of bug 879327
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
18
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-15 23:05 EST by Ankur Sinha (FranciscoD)
Modified: 2013-01-16 03:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-16 03:32:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ankur Sinha (FranciscoD) 2013-01-15 23:05:35 EST
Description of problem:
A missing service file prevents boot.


Version-Release number of selected component (if applicable):
3.2.6-11.fc18.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Update mdadm to -11
2.Poweroff
3.boot
  
Actual results:
GDM does not come up

Expected results:
GDM should come up

Additional info:
/var/log/messages is littered with:

21630 Jan 16 14:54:32 dhcppc1 systemd[1]: Cannot add dependency job for unit mdmonitor-takeover.service, ignoring: Unit mdmonitor-takeover.servic           e failed to load: No such file or directory. See system logs and 'systemctl status mdmonitor-takeover.service' for details.
Comment 1 Ankur Sinha (FranciscoD) 2013-01-15 23:08:29 EST
A workaround is here: https://bugzilla.redhat.com/show_bug.cgi?id=879327#c13

Switching to a virtual terminal, and running:

# 
# sudo mdmon --all --takeover --offroot
# sudo systemctl restart gdm.service

got GDM to come up normally.
Comment 2 Jes Sorensen 2013-01-16 03:32:44 EST
This is probably related to 879327 and has nothing to do with gdm itself.
If gdm really depends on the takeover service running, the problem is with
gdm, however there is no indication of this in:
/usr/lib/systemd/system/gdm.service

*** This bug has been marked as a duplicate of bug 879327 ***

Note You need to log in before you can comment on or make changes to this bug.